Request: Nightly FirefoxOS engineering builds for nexus-4, please

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: djf, Assigned: aki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
It appears that FirefoxOS user builds for nexus-4 are created nightly and stored on pvtbuilds.mozilla.com. I can use these builds to flash my nexus 4 and run FirefoxOS. But it doesn't give me root, so the phone is useless for Gaia development.  

The gecko and gonk developers probably already create their own builds and don't care about the nightlies.  But building kernels is not a good use of time for gaia developers.

Given that we are not sharing these builds outside of mozilla, I would guess that at least half of the people who want to use nexus 4 builds are gaia developers who need rooted builds.

Could we produce these automatically, please?

I know that nexus-4 is not really an officially supported platform, but right now, on the Media Frontend team, we need to use nexus 4 for our 1.4 camera work and for NFC work as well.
Component: Release Automation → General Automation
QA Contact: bhearsum → catlee
David, is this primarily to help with MWC preparations or is this going to be useful beyond that time as well (after we've moved over to reference devices as our primary dev hardware)?
Flags: needinfo?(dflanagan)
(Reporter)

Comment 2

4 years ago
Developers on the front end media team have recently acquired nexus 4 devices for our work with NFC and Camera. This is a stopgap until we have reference devices, but is not specifically tied to MWC.

I actually don't know what the camera specs on the reference device are. We may need to continue to use nexus 4s for work on the Madai camera because it may support features that our new reference device does not.
Flags: needinfo?(dflanagan)

Updated

4 years ago
Whiteboard: [b2g]

Updated

4 years ago
Duplicate of this bug: 978923
+1 - We need this ASAP to run integration tests for Madai.
Our partner is writing integration tests and they use Nexus4 devices. Can we prioritize this?
I've been asked to weigh in here to get a better understanding of the need here. Questions:

1. Why do we need engineering builds for test automation? Integration tests to my understanding run on b2g desktop builds right now, not on device. The only on device automation we've got is Gaia UI Tests, which are only planned to be ran on the target reference device of the release (1.3 = Buri, 1.4 = Flame).

2. Do we know why the user builds don't have root access? Can we change our build generation process for user builds to have root access by default?
jsmith: In particular, our partner is writing integration tests on Nexus4 for the Camera app. The Camera app cannot be tested on b2g desktop and needs to run on the device.
Any update on getting these builds automated?
(Assignee)

Updated

4 years ago
Assignee: nobody → aki
(Assignee)

Comment 9

4 years ago
Created attachment 8391640 [details] [diff] [review]
nexus4-eng

Worked in staging.
Attachment #8391640 - Flags: review?(bhearsum)
Attachment #8391640 - Flags: review?(bhearsum) → review+
(Assignee)

Comment 10

4 years ago
Comment on attachment 8391640 [details] [diff] [review]
nexus4-eng

https://hg.mozilla.org/build/buildbot-configs/rev/9a1e4543d0b8
Attachment #8391640 - Flags: checked-in+
(Assignee)

Updated

4 years ago
Depends on: 984428
in production
(Assignee)

Comment 12

4 years ago
Created attachment 8392469 [details] [diff] [review]
n4eng-tbpl-symbol
Attachment #8392469 - Flags: review?(ryanvm)
Comment on attachment 8392469 [details] [diff] [review]
n4eng-tbpl-symbol

Review of attachment 8392469 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry, should have caught that the first time around.
Attachment #8392469 - Flags: review?(ryanvm) → review+
(Assignee)

Comment 14

4 years ago
Comment on attachment 8392469 [details] [diff] [review]
n4eng-tbpl-symbol

https://hg.mozilla.org/webtools/tbpl/rev/2d30e10a4cbe
Attachment #8392469 - Flags: checked-in+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Created attachment 8392629 [details] [review]
GitHub Pull Request - B2G-flash-tool

I updated the B2G-flash-tool to allow these new ENG builds to be flashed through there. Can you please review and/or merge this patch? Thanks!
Attachment #8392629 - Flags: review?(ryanvm)
Comment on attachment 8392629 [details] [review]
GitHub Pull Request - B2G-flash-tool

I am definitely not an appropriate reviewer for this.
Attachment #8392629 - Flags: review?(ryanvm)
Attachment #8392629 - Flags: review?(fyen)
(In reply to Aki Sasaki [:aki] from comment #14)
> Comment on attachment 8392469 [details] [diff] [review]
> n4eng-tbpl-symbol
> 
> https://hg.mozilla.org/webtools/tbpl/rev/2d30e10a4cbe

In production :)
Comment on attachment 8392629 [details] [review]
GitHub Pull Request - B2G-flash-tool

Merged.
https://github.com/Mozilla-TWQA/B2G-flash-tool/commit/5a027152e647081f32bd71eb2e9e74f695778e53
Attachment #8392629 - Flags: review?(fyen) → review+
You need to log in before you can comment on or make changes to this bug.