Closed Bug 967760 Opened 6 years ago Closed 6 years ago

[B2G][Status Bar] AM/PM cut-off in status bar when device is using 12 hour clock and multiple status are enabled

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: tnguyen, Assigned: benfrancis)

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file)

Attached image screenshot
Description:
While having multiple features (Bluetooth, Cellular data, Radio with headphones in, and USB enabled) the AM or PM for the 12 hour clock will be cut off. 

Repro Steps:
1) Updated Buri to BuildID: 20140204040201
2) Have Cellular Data enabled during FTU/FTE
3) Navigate to Settings App
4) Tap on Bluetooth > Tap on Bluetooth again to enable
5) Go back a menu by taping "<" icon on top left of screen
6) Scroll down and tap on USB storage to enable it
7) Connect device to a computer with USB cable
8) Plug in headphones to device
9) Tap on Radio App and tap the play icon

Actual Result:
12 hour clock information will be cut off from status bar

Expected Result:
Clock information is not cut off from status bar

Environmental Variables:
Device: Buri Master M-C mozRIL
BuildID: 20140204040201
Gaia: 75e9691f02b9d18585c18a5434beeff39ee7ea20
Gecko: c150845d077d
Version: 30.0a1
v1.2-device.cfg

Attached: screenshot
This is a regression from introducing the rocketbar.
blocking-b2g: --- → 1.4?
Component: General → Gaia::System
Keywords: regression
Whiteboard: [systemsfe]
Assignee: nobody → bfrancis
Rocketbar is being turned off for 1.4, so I'm clearing the flag. Will file a separate bug to pref off rocketbar.
blocking-b2g: 1.4? → ---
Jason, I'm not able to reproduce this with Rocketbar turned on or off. Have you tested that it is definitely fixed when Rocketbar is turned off? The new HTML structure and CSS styles are still used even with Rocketbar turned off.
Flags: needinfo?(jsmith)
(In reply to Ben Francis [:benfrancis] from comment #3)
> Jason, I'm not able to reproduce this with Rocketbar turned on or off. Have
> you tested that it is definitely fixed when Rocketbar is turned off? The new
> HTML structure and CSS styles are still used even with Rocketbar turned off.

I'll put qawanted for someone to see if this still reproduces with rocketbar off & on.

Note - for verifying if this reproduces with rocketbar, try testing this on last Friday's build.
Flags: needinfo?(jsmith)
QA Contact: ktucker
I could not reproduce this issue on the latest Buri v 1.4.0 Mozilla RIL which has Rocketbar turned off. 

Environmental Variables
Device: Buri v 1.4.0 Mozilla RIL
Build ID: 20140226040201
Gecko: https://hg.mozilla.org/mozilla-central/rev/626d99c084cb
Gaia: 80d6405725788327102cab36e8d8c017cf25fb23
Platform Version: 30.0a1
Firmware Version: v1.2-device.cfg

Also, I could not reproduce this on Friday's Buri v 1.4.0 Mozilla RIL build which has Rocketbar turned on.

Environmental Variables
Device: Buri v 1.4.0 Mozilla RIL
Build ID: 20140221040202
Gecko: https://hg.mozilla.org/mozilla-central/rev/7010ab83a06e
Gaia: 35365feace970bfc51276428f40a477c9c86b7bb
Platform Version: 30.0a1
Firmware Version: v1.2-device.cfg

The clock appeared correctly in the status bar.
Keywords: qawanted
No longer blocks: rocketbar-search-mvp
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.