Using onresize() causes infinite redraw loop

RESOLVED INVALID

Status

Core Graveyard
Embedding: GTK Widget
RESOLVED INVALID
17 years ago
6 years ago

People

(Reporter: Patrice Belleville, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I set up a Web site for a course with a header, a footer, and a body
that contains two internal frames: a menu and one with contents. The
height of the internal frames is computed dynamically based on the height
of the browser window. Hence the iframes are redrawn every time the browser
window is resized.

This is accomplished by using 'onresize="setupContents()"' in the body tag,
where setupContents() is a Javascript function (see the URL for the details
of the code).

This works fine with IE 5.0 and above, and with Mozilla 0.9.3. The problem
occurs when using Galeon. Galeon 0.12 (as well as 0.12pre1 and 0.12pre3) keeps
redrawing the internal frame over and over again (the ensuing flicker is
extremely annoying to watch).

The problem goes away if I delete the 'onresize="setupContents()"'
from the <body> tag [but of course then the page isn't redrawn when the
user resizes his/her browser window].

The problem also occurs with the 20010814 build of Mozilla 0.9.3 installed. 

Here's what one of the Galeon developers (mpeseng@tin.it) had to say about it:

------- Additional Comments From Marco Pesenti Gritti 2001-08-22 10:39 -------

it looks like a mozilla embedding bug .. please report it on
bugzilla.mozilla.org

Comment 1

17 years ago
Sorry this was a galeon bug :( I think it can be closed
(Assignee)

Comment 2

17 years ago
OK, closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.