Don't access docshell from WindowIsClosing

VERIFIED FIXED in Firefox 30

Status

()

Firefox
General
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: billm, Assigned: billm)

Tracking

unspecified
Firefox 30
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Created attachment 8370380 [details] [diff] [review]
window-is-closing

When I click on the close box in Windows, the window doesn't close. This patch fixes the problem.
Attachment #8370380 - Flags: review?(felipc)
Comment on attachment 8370380 [details] [diff] [review]
window-is-closing

please:

if (gMultiProcessBrowser)
  return true;
Attachment #8370380 - Flags: review?(felipc) → review-
(Assignee)

Comment 2

4 years ago
Created attachment 8370386 [details] [diff] [review]
window-is-closing v2
Attachment #8370380 - Attachment is obsolete: true
Attachment #8370386 - Flags: review?(felipc)

Updated

4 years ago
Attachment #8370386 - Flags: review?(felipc) → review+
(Assignee)

Comment 3

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b5ac830019b1
https://hg.mozilla.org/mozilla-central/rev/b5ac830019b1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30

Updated

4 years ago
Keywords: verifyme
(In reply to Bill McCloskey (:billm) from comment #0)
> When I click on the close box in Windows, the window doesn't close
I can't reproduce this in Nightly 2014-02-04, 2014-02-05 Win 7 x64.
Thoughts ?
Flags: needinfo?(wmccloskey)
(Assignee)

Comment 6

4 years ago
Sorry, I don't know.
Flags: needinfo?(wmccloskey)

Updated

4 years ago
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.