<element height="100%"> in <p> causes the element to have zero height for replaced elements

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: Robert Seifert, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: quirks only)

Attachments

(1 attachment)

366 bytes, text/html
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3+)
Gecko/20010823
BuildID:    2001082303

When i surf to this site http://www.kickbox.nu/beta/beta2/sve/index02.htm
with IE i see all the content of the page, but with mozilla
I can only see the menu, not the content!
Maybe this problem exists in all the OS???
Please don't tell me this is a dupe! ;)

Reproducible: Always
Steps to Reproduce:
Just go to this url!

Actual Results:  You will see that the page won't show, only the menu!

Expected Results:  Show the whole contents of the main page!
On quick inspection, there are some checks for document.layers in there.  I'm
assuming the rest of the site uses layers also.  I'm wondering if there is also
a user-agent sniff going on that is refusing NS6 because I see "Din browser
stödjer tyvärr inte frames, skaffa Netscape 6 eller IE 4.x" in one of the
frames.  I have no clue what that means though.

Over to tech evangelism for further triage with a best-guess assign to Europe
since the language looks scandinavian.  Re-assign if I'm wrong.
Assignee: pollmann → nitot
Component: HTMLFrames → European
Product: Browser → Tech Evangelism
QA Contact: amar → momoi
Version: other → unspecified
(Reporter)

Comment 2

17 years ago
Well, umm.. It's my homepage! ;)

Not good source in there yet..

It says: You must have netscape 6.x or IE 4.x to get this to work!
Dunno why I wrote that... Because at that time I thouht that Netscape 6
would support it!
(Reporter)

Comment 3

17 years ago
By the way.. The language is Swedish! So Scandinavian was a good guess..
Dunno why Netscape/mozilla can't display it though!
(Reporter)

Comment 4

17 years ago
Well.. One person that I talked with on #Mozillazine found the bug:
Its a bug in mozilla that hides the iframe when you do border="0" and 
height="100%"  .... 

Comment 5

17 years ago
per irc, over to htmlframes
Assignee: nitot → pollmann
Status: UNCONFIRMED → NEW
Component: European → HTMLFrames
Ever confirmed: true
Product: Tech Evangelism → Browser
QA Contact: momoi → amar
Version: unspecified → other

Comment 6

17 years ago
Changing summary
this only affects quirks mode
will attach simplified testcase that uses <img>
Summary: Doesn't display page right → <element height="100%"> in <p> causes the element to have zero height for replaced elements

Comment 7

17 years ago
Created attachment 47161 [details]
testcase
(Reporter)

Comment 8

17 years ago
Will this bug be accepted?

Comment 9

17 years ago
If I'm not mistaken I think this belongs in layout
Assignee: pollmann → karnaze
Component: HTMLFrames → Layout
QA Contact: amar → petersen
Whiteboard: quirks only
(Reporter)

Comment 10

17 years ago
Layout sounds good 2 me! :)
(Reporter)

Comment 11

16 years ago
http://www.kickbox.nu/beta/beta2/sve/index02.htm is no longer
available! If you want exampel, look at the attachment basic did!

Comment 12

16 years ago
this might be a dup of bug 85016 marking depend for now
Depends on: 85016

Comment 13

16 years ago
Testcase is fixed by the fix for 85016 - marking FIXED
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

16 years ago
Yippie! :) Thanx!
You need to log in before you can comment on or make changes to this bug.