SeaMonkey 2.24 ignores download folder setting

RESOLVED FIXED in seamonkey2.24

Status

SeaMonkey
Download & File Handling
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Robert Roessler, Unassigned)

Tracking

({regression})

SeaMonkey 2.24 Branch
seamonkey2.24
x86_64
Windows 8.1
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
SeaMonkey 2.24 (starting with B1) now ignores the "When saving a file" preference setting, and instead uses the Windows "Downloads" folder for the current user.. IFF the selected folder from the preference setting is the root of a drive (e.g., "Z:\", which is always just saved as "Z:").

This has worked as intended - storing to the root of the drive - until the 2.24 BETA 1.

Comment 1

4 years ago
Confirmed behavior change.

STR:

Edit | Preferences | Browser | Downloads -> Save files to Z:
(where Z: is the root of a drive, local, non-network drive is fine)

Save something; a file, an image

Results:

SM 2.23 saves the file to Z:
SM 2.24 saves the file to %USERPROFILE%\My Documents\Downloads

If this were the root of a system drive, I could see where you would not want to save files, or even have the ability to save files there, but in this case, Z: is simply the root of a non-system (data if you will) drive.

Comment 2

4 years ago
Could be this the same problem as bug 958899 ?

Comment 3

4 years ago
(In reply to simone.lando from comment #2)
> Could be this the same problem as bug 958899 ?

Looks like it. Thanks for the notice.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 958899
(Reporter)

Comment 4

4 years ago
Nice... one of the "benefits" of sharing a code base with the FF crowd?

The bug this is apparently a dupe of may be fixed Real Soon Now... a fix for one of its 2 blockers is checked in (somewhere), and the other may be fixed in a day or so.
Resolution: DUPLICATE → FIXED
You need to log in before you can comment on or make changes to this bug.