Switching between Metro/Desktop leaves Firefox Metro splash behind (also creates new instances of Firefox Desktop)

RESOLVED DUPLICATE of bug 960702

Status

Firefox for Metro
Browser
RESOLVED DUPLICATE of bug 960702
4 years ago
4 years ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
When you're switching from Firefox Metro -> Firefox Desktop, the Firefox Metro process is closed and the Firefox Desktop process is started but you'll notice that the Firefox Metro splash screen is left behind under the "App List". If you select Firefox Metro from the "App List", it will start launching Firefox Metro and then dump the user into the Windows Metro environment. Taping on the Firefox Metro tile will create a new instance of Firefox Desktop rather than switching back to the desktop environment.

Created a video to illustrate the issue
- http://youtu.be/HiCvN4h-JJ0

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to any website, in this case I visited mozilla.org
3) Once the website has loaded, slide in the "Navigation App Bar" and tap on the "Settings" icon
4) Select "Relaunch in Desktop"
5) Firefox Desktop will open under the desktop environment
6) Slide in the "App List" and you'll notice that the Firefox Metro splash screen is still visible
7) Tap on the Firefox Metro splash screen and Firefox Metro will start launching and then dump the user into the Windows Metro environment. While this happens, a new instance of Firefox Desktop is opened at the same time.

Current Behaviour:

- When switching between Firefox Metro -> Firefox Desktop, the Firefox Metro splash screen is left behind under the "App List". Taping on the Firefox Metro tile opens a brand new instance Firefox Desktop every single time.

Expected Behaviour:

- When a user switches from Firefox Metro into Firefox Desktop, Firefox Metro should be completely closed. Taping/clicking on the Firefox Metro tile should switch back to the Firefox Desktop environment until the user selects "Windows 8 Touch" to go back into Metro mode.

Found the issue using the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-04-03-02-01-mozilla-central/
Dupe of bug 960702?

Updated

4 years ago
Whiteboard: [triage] [defect] p=0 → [triage] [defect] p=0 Dupeme

Comment 2

4 years ago
(In reply to juan becerra [:juanb] from comment #1)
> Dupe of bug 960702?

Looks like it.

Anyone know if this is reproducible in IE?

Updated

4 years ago
No longer blocks: 838081, 924911
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: [triage] [defect] p=0 Dupeme
Duplicate of bug: 960702
You need to log in before you can comment on or make changes to this bug.