Closed Bug 968049 Opened 7 years ago Closed 7 years ago

sometimes starting browser shows "Firefox can't find the file at app://browser.gaiamobile.org/null" instead of start page

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.4 S1 (14feb)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: dbaron, Assigned: benfrancis)

Details

(Keywords: regression, Whiteboard: [systemsfe][p=2])

Attachments

(2 files)

Since I upgraded from 1.2 to 1.3 (about a month ago??) I've been seeing occasionally, when I start the browser app, an error page showing:

  Unable to connect
  Firefox can't find the file at app://browser.gaiamobile.org/null

(For a while, the whole error page was %-escaped, but that has since been fixed.)

I've been unable to figure out exact steps to reproduce, though bug 875199 comment 4 suggests it might be related to out of memory (maybe the OOM killer killing the content process inside the browser?)


Steps to reproduce:
 1. ???
 2. start the browser app

Actual results:  Network error page showing:
  Unable to connect
  Firefox can't find the file at app://browser.gaiamobile.org/null

Expected results: start page showing my 4 most recently visited pages
Note that this is in a self-built 1.3 on a hamachi.  I've seen it most recently, this morning, in a build I did yesterday.
This sounds like a data migration bug.

QA Wanted - Can someone check to see if they can reproduce this bug by doing some exploratory data migration tests on Leo from 1.2 to 1.3 using the browser?
John

Please review and closely follow up.
Flags: needinfo?(jhammink)
I'm not generally seeing this on my 1.3 testing, on Buri or Sora, at least.

However, I'll leave the needinfo flag on this one and recheck back from time to time.
(In reply to John Hammink from comment #4)
> I'm not generally seeing this on my 1.3 testing, on Buri or Sora, at least.
> 
> However, I'll leave the needinfo flag on this one and recheck back from time
> to time.

Buri & Sora isn't the right way to reproduce this - you need to perform a data migration from 1.2 to 1.3.
I don't think this is a data migration issue, it's just a straight bug. We need reliable STR to act on this, I've never reproduced it myself.
David,

Can you please provide STR? Is this happening upon upgrade from 1.2 to 1.3 only?
Flags: needinfo?(dbaron)
(In reply to Preeti Raghunath(:Preeti) from comment #7)
> Can you please provide STR?

I can reproduce reliably using the following steps:
 1. hold down the home button and kill all running apps by clicking the (X) for each
 2. start the browser app
 3. wait for the start screen showing four recent pages to appear
 4. press the home button
 5. start the email app
 6. tap the compose icon
 7. tap the (+) icon in the "To" to start the contacts app
 8. choose a contact's email address
 9. click the < icon and then choose to discard the email
10. start the Browser app

(In my experience, starting both email and contacts is enough to OOM-kill everything else.)

> Is this happening upon upgrade from 1.2 to 1.3 only?

I don't know.
Flags: needinfo?(dbaron)
Oops, this:

> 10. start the Browser app

should have been:

10. press the home button
11. start the browser app
And, in case it's not obvious, the above steps are probably valid only for devices with 256MB of RAM.
Keywords: dataloss
Keywords: qawanted
No longer blocks: 1.3-data-migration
nhirata to talk to dbaron about his device.
Flags: needinfo?(nhirata.bugzilla)
(In reply to David Baron [:dbaron] (needinfo? me) (UTC-8) from comment #8)
> (In reply to Preeti Raghunath(:Preeti) from comment #7)
> > Can you please provide STR?
> 
> I can reproduce reliably using the following steps:
>  1. hold down the home button and kill all running apps by clicking the (X)
> for each
>  2. start the browser app
>  3. wait for the start screen showing four recent pages to appear
>  4. press the home button
>  5. start the email app
>  6. tap the compose icon
>  7. tap the (+) icon in the "To" to start the contacts app
>  8. choose a contact's email address
>  9. click the < icon and then choose to discard the email
> 10. start the Browser app
> 
> (In my experience, starting both email and contacts is enough to OOM-kill
> everything else.)

I can reproduce this with my inari with a local 1.3 build from Friday.  I'll try to reproduce with a build not done by me.

> > Is this happening upon upgrade from 1.2 to 1.3 only?
> 
> I don't know.

Since I can reproduce this with a clean flash of 1.3 so it seems to not be specific to upgrades.
I cannot reproduce this with a build that was produced by releng.  Since I *can* reproduce with a build I did myself, I presume this is something to do with the memory usage of VARIANT=eng vs. VARIANT=user.

Ben, is this enough to go on?
Flags: needinfo?(bfrancis)
Yep, I just reproduced this using Andrew's steps above.  

Gaia      00cd1ae74dfe773a41b55275b0b468a62f35076d
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/873e98e750bf
BuildID   20140211004035
Version   28.0
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
(In reply to John Hammink from comment #14)
> Yep, I just reproduced this using Andrew's steps above.  

Can you attach any and all logs, John?
Tried reproducing several times to get logs; even after a reflash.  Unfortunately could repro this on latest 1.3 exactly once.
I was using a VARIANT=user build.

I'd comment that the goal of loading mail and contacts is to run the device out-of-memory -- it might be that if you, say, haven't added any contacts, that's not enough -- so it might help to either (a) set up linking contacts to facebook or google or (b) use some additional apps in addition to mail and contacts.
Oh yeah, I forgot to say that each time I did this I imported ~300 Google contacts.  This unfortunately includes the time when I couldn't reproduce it with a build produced by releng.
Attached image screenshot
Triage decided to block on this.  Ben told me on IRC that he knew what was going on so I'm giving the bug to him.
Assignee: nobody → bfrancis
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(jhammink)
Flags: needinfo?(bfrancis)
Thanks Andrew, that screenshot helped a lot.

What's going on here is that when we launch the browser it opens an empty tab in the background behind the start page. The OOM is killing that tab, then when you switch back to the browser it revives the tab and reloads the URL, but the URL is null which is why you get the error. It should just leave you on the start screen instead.

I don't think this is a regression, I just don't think we've ever noticed it before because opening the browser app at the start page then going back to the homescreen before doing anything else is a relatively uncommon use case.
Whiteboard: [systemsfe][p=2]
Target Milestone: --- → 1.4 S1 (14feb)
https://github.com/mozilla-b2g/gaia/commit/164d7d821a3650eec2eb10164bda9d4cdf2bfb33
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Oh, gosh, if I knew you'd wanted a screenshot, I'd have given you a screenshot sooner.
1.3 blockers no longer have auto-approval to land. Please request gaia-v1.3 approval on the patch for uplift.
Attachment #8374922 - Flags: approval-gaia-v1.3+
v1.3: 44273233e439245b696349b17ee0f20da7025f95
You need to log in before you can comment on or make changes to this bug.