Closed Bug 968069 Opened 7 years ago Closed 7 years ago

[B2G][L10n][Gallery] Chinese Traditional: Month in thumbnail mode not localizable

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
1.4 S1 (14feb)

People

(Reporter: petercpg, Assigned: flod)

References

Details

(Keywords: l12y, Whiteboard: LocRun1.3)

Attachments

(3 files)

Attached image 2014-02-05-15-50-56.png
Expected Results: "2013 年 11 月", a Chinese way to note month name.

Actual Results: "十一月 2013", which is a western-style mm/yyyy order.

Device: Geeksphone Keon
Build: 20140205010019
Gaia: 3405205
Platform Version: 28.0
This should be the code
https://github.com/mozilla-b2g/gaia/blob/master/apps/gallery/js/thumbnail_date_group.js#L63

I'm looking at shared/date/date.properties but I don't see an existing useful date format.
Attached image Local test on Keon
Tested locally on a Keon.

Left: original
Right: with string set to "%Y…%B"
Comment on attachment 8372128 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/16073

Change looks good to me, but forwarding to gallery peer
Attachment #8372128 - Flags: review?(dale) → review?(dflanagan)
blocking-b2g: --- → 1.3?
Actually, let's check something before the nom. Did we ever support a localized format here?
blocking-b2g: 1.3? → ---
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #5)
> Actually, let's check something before the nom. Did we ever support a
> localized format here?

i.e. QA Wanted to see what happens with 1.2 with locales that produce an alternative date format.
I didn't ask for 1.3? because this patch adds a new string, and I think we're pretty tight on these at the moment. In case we also need late-l10n
Comment on attachment 8372128 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/16073

r+. Thanks, Francesco!

Jason: before 1.3 the Gallery never displayed dates. So this isn't a regression, just a bug in a new feature.

If we can do the late-l10n thing, I'd love to get this fixed correctly in 1.3.

If we can't add a string at this point, I'd be willing to land a patch that hardcoded "year month" dates like "2014 February" instead of the current hardcoded month year format that we have now.  For quickly scrolling through your photos, there's a good argument to be made that you want to see the year first, anyway. So if you want to do that, please submit a patch that changes %B %Y to %Y %B on the 1.3 branch, and ask Punam to review.

Punam: here's another date localization bug I wanted to bring to your attention.

Francesco: you may find that the same date localization bugs exist in the Video app.  If so, Punam can review your patches there, as well.
Attachment #8372128 - Flags: review?(dflanagan) → review+
Flags: needinfo?(pdahiya)
I suspect that the failing test for this patch was an unrelated transient failiure, and I've restarted the Travis build.
Thanks David, Travis passed this time.

> Francesco: you may find that the same date localization bugs exist in the
> Video app.  If so, Punam can review your patches there, as well.

I'll look into this and file another bug.

(In reply to David Flanagan [:djf] from comment #8)
> If we can do the late-l10n thing, I'd love to get this fixed correctly in
> 1.3.

Hard-coding "%B %Y" would probably look awkward for the majority of locales (it sounds "mechanical" in Italian), and we're very late in the process to add a new string. 

Asking Pike's opinion here before setting keyword and approval, my personal take would be let's keep this on 1.4 and let it ride the train.
Flags: needinfo?(l10n)
As noted by David in Comment 8, this fix should also be done in Video App inside apps/video/js/thumbnail_date_group.js. 

Francesco, thanks for fixing the header to have localized format, it looks good. please feel free to assign review flag for this fix in video app.
Flags: needinfo?(pdahiya)
Keywords: checkin-needed
Assignee: nobody → francesco.lodolo
Master: f038eac8de2cfd98fa1d19b97805cc624ddd40e7
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S1 (14feb)
Keywords: qawanted
I'd let this ride the trains.
Flags: needinfo?(l10n)
Verified on 1.4 (2014-03-02, git 46b455c9)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.