Bug 96809 (NoPluginUnload)

plugins don't get unloaded and preloaded mozilla keeps getting bigger

VERIFIED DUPLICATE of bug 115450

Status

()

VERIFIED DUPLICATE of bug 115450
18 years ago
17 years ago

People

(Reporter: andrea.aime, Assigned: serhunt)

Tracking

({memory-leak})

Trunk
x86
Windows NT
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    

When a plugin (Java, Acrobat) gets loaded it never gets unloaded
any more, and using preloader results in a background process
that grows in time and sucks big quantities of system memory...

Reproducible: Always
Steps to Reproduce:
1. use preloader under windows
2. go to java.sun.com, open some pdf with Acrobat plugin
3. close all windows
4. look at mozilla's memory consumption: terrible!

Actual Results:  Mozilla's background process sucks between 
50 and 70 MB of memory even if no window is opened

Expected Results:  Plugins should be unloaded when the last open window
is closed, releasing memory

Comment 1

18 years ago
Apps or Plug-ins. Not sure who would make this happen. Trying XP Apps first.
Assignee: asa → pchen
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
QA Contact: doronr → sairuh
shrir, would this be plug-ins? punt as needed, thx!
Assignee: pchen → av
Component: XP Apps → Plug-ins
Keywords: mlk
QA Contact: sairuh → shrir
(Assignee)

Comment 3

18 years ago
Acrobat plugin is a fairly small thing. The real Acrobat engine uses separate
process space. I am not sure how big Java is but I beleive the problem is not
limited to plugins. Open mail client e.g., you'll see memory increase too and it
is not freed after closing all the windows. As to plugins, all legacy plugins
are unloaded from the memory when the page is left. Java probably stays, as do
xpcom plugins of which we have only Real Player in the installation package.

Not sure what to do with this bug. Any ideas?

Comment 4

18 years ago
Uh....I think that's exactly what the preloader is supposed to do.....leave
stuff loaded so next time you use it it's already loaded. Therefore, I believe
that this bug should be marked WONTFIX.

In addition, because of the special nature of the Java plugin, it is not
designed to be unloaded once loaded unless the application will be terminated.
Since the preloader prevents the termination of Mozilla, once loaded, the Java
plugin will remain in memory. As for Acrobat, it is a 4.x-style plugin and DOES
get unloaded when the last instance is unloaded. The Acrobat application is
independant of the browser so it remaining loaded is probably an issue for Adobe.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 5

17 years ago
v
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
*** Bug 146067 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
*** Bug 152039 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
*** Bug 155204 has been marked as a duplicate of this bug. ***
*** Bug 158125 has been marked as a duplicate of this bug. ***
*** Bug 158393 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Alias: NoPluginUnload

Comment 11

17 years ago
I am reopening this bug given this consideration (on Windows)

Run Mozillia as a mail client                          - 15Mb
Open browse window                                     - 17Mb
view java page                                         - 30Mb
close browse window leaving *only* mail client running - 30Mb

That can not be a desired feature.
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---

Comment 12

17 years ago
What are the results with disabling Java? Do different versions of the JRE make
a difference?

Comment 13

17 years ago
Java configuration and version are irrelevent to this bug.  Any version will be
loaded, and won't be unloaded.  The same is true with all other plugins.  The
most you can do is figure out which version of the JRE uses fewer resources,
because all you can hope to accomplish is a smaller load on your system when the
bug manifests itself.

Comment 14

17 years ago
Regular plugins do get unloaded. Otherwise we'd have other bugs. XPCOM and
XPConnected plugins, however, need to remain in memory otherwise we crash.

*** This bug has been marked as a duplicate of 115450 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 15

17 years ago
vd
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.