sometimes characters aren't escaped properly in the body tag - breaking (dev) Marketplace

RESOLVED WORKSFORME

Status

Marketplace
Consumer Pages
P1
critical
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: eviljeff, Unassigned)

Tracking

2014-02-11
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8370697 [details]
dev Marketplace view source

I can't load marketplace-dev, apparently because the data-languages attribute isn't properly encoded.  
so it looks like this:
<body class="home" data-languages="["af", "ar", "bg", "ca", "cs", "da", "de", "el", "en-US", "es", "eu", "fa", "fi", "fr", "ga-IE", "he", "hu", "id", "it", "ja", "ko", "mn", "nl", "pl", "pt-BR", "pt-PT", "ro", "ru", "sk", "sl", "sq", "sr", "sr-Latn", "sv-SE", "tr", "uk", "vi", "zh-CN", "zh-TW", "dbg"]" data-settings="{"persona_unverified_issuer": "login.persona.org"}" data-build-id-js="0017804-52f18b19" data-media="https://marketplace-dev-cdn.allizom.org/media/" data-repo="fireplace">

see attachment
(Reporter)

Comment 1

4 years ago
Created attachment 8370698 [details]
Prod Marketplace view source
When working correctly, we should see:
<body class="home" data-languages="[&#34;ca&#34;, &#34;cs&#34;, &#34;de&#34; (...)

When curl-ing https://marketplace-dev.allizom.org/ it seems to alternate between the 2 versions (X-Backend-Server and Via headers stay the same though)

Can't reproduce in stage or production.

Updated

4 years ago
Priority: -- → P1
Target Milestone: --- → 2014-02-11

Updated

4 years ago
Duplicate of this bug: 968203
I can't reproduce at all. Who can? Steps please!
Keywords: steps-wanted
(Reporter)

Comment 5

4 years ago
1) curl https://marketplace-dev.allizom.org/
2) repeat 1) until you get a broken response :)

The bad part is the caching means that in Firefox even a ctrl+F5 doesn't fix it.  (I guess the cache will expire at some point)
(Reporter)

Updated

4 years ago
Keywords: steps-wanted
(In reply to Andrew Williamson [:eviljeff] from comment #5)
> 1) curl https://marketplace-dev.allizom.org/
> 2) repeat 1) until you get a broken response :)
> 
> The bad part is the caching means that in Firefox even a ctrl+F5 doesn't fix
> it.  (I guess the cache will expire at some point)

Can you paste the command and the output? I can't reproduce :(
(Reporter)

Comment 7

4 years ago
hmm.  Neither myself nor Mat can replicate today so calling it closed until we see it again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.