crash in nsMsgHeaderParser::ParseDecodedHeader(nsAString_internal const&, bool, unsigned int*, msgIAddressObject***)

RESOLVED DUPLICATE of bug 961564

Status

MailNews Core
MIME
--
critical
RESOLVED DUPLICATE of bug 961564
5 years ago
5 years ago

People

(Reporter: Usul, Unassigned)

Tracking

({crash, regression})

Trunk
All
Mac OS X
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-fd9a98c8-ec77-4fd1-b58c-63a2d2140205.
=============================================================


This looks like a very recent regression.
(Reporter)

Updated

5 years ago
Component: General → MIME
Product: Core → MailNews Core
(Reporter)

Comment 1

5 years ago
0 	XUL 	nsMsgHeaderParser::ParseDecodedHeader(nsAString_internal const&, bool, unsigned int*, msgIAddressObject***) 	objdir-tb/x86_64/mozilla/dist/include/nsCharTraits.h
1 	XUL 	mozilla::mailnews::DecodedHeader(nsAString_internal const&) 	mailnews/mime/src/MimeHeaderParser.cpp
2 	XUL 	nsMsgDatabase::RowCellColumnToAddressCollationKey(nsIMdbRow*, unsigned int, unsigned char**, unsigned int*) 	mailnews/db/msgdb/src/nsMsgDatabase.cpp
3 	XUL 	nsMsgDBView::GetCollationKey(nsIMsgDBHdr*, int, unsigned char**, unsigned int*, nsIMsgCustomColumnHandler*) 	mailnews/base/src/nsMsgDBView.cpp
4 	XUL 	nsMsgDBView::Sort(int, int) 	mailnews/base/src/nsMsgDBView.cpp
5 	XUL 	nsMsgThreadedDBView::SortThreads(int, int) 	mailnews/base/src/nsMsgThreadedDBView.cpp
6 	XUL 	nsMsgThreadedDBView::Sort(int, int) 	mailnews/base/src/nsMsgThreadedDBView.cpp
7 	XUL 	nsMsgThreadedDBView::InitSort(int, int) 	mailnews/base/src/nsMsgThreadedDBView.cpp
8 	XUL 	nsMsgThreadedDBView::InitThreadedView(int*) 	mailnews/base/src/nsMsgThreadedDBView.cpp
9 	XUL 	nsMsgThreadedDBView::Open(nsIMsgFolder*, int, int, int, int*) 	mailnews/base/src/nsMsgThreadedDBView.cpp
10 	XUL 	NS_InvokeByIndex 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp
11 	XUL 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp
12 	XUL 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp
13 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/jscntxtinlines.h
14 	XUL 	Interpret 	js/src/vm/Interpreter.cpp
15 	XUL 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
16 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
17 	XUL 	js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value*, JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
18 	XUL 	js::DirectProxyHandler::call(JSContext*, JS::Handle<JSObject*>, JS::CallArgs const&) 	js/src/jsproxy.cpp
19 	XUL 	js::CrossCompartmentWrapper::call(JSContext*, JS::Handle<JSObject*>, JS::CallArgs const&) 	js/src/jswrapper.cpp
20 	XUL 	js::Proxy::call(JSContext*, JS::Handle<JSObject*>, JS::CallArgs const&) 	js/src/jsproxy.cpp
21 	XUL 	js::proxy_Call(JSContext*, unsigned int, JS::Value*) 	js/src/jsproxy.cpp
22 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/jscntxtinlines.h
23 	XUL 	Interpret 	js/src/vm/Interpreter.cpp
24 	XUL 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
25 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
26 	XUL 	js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value*, JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
27 	XUL 	JS::Call(JSContext*, JS::Value, JS::Value, unsigned int, JS::Value*, JS::MutableHandle<JS::Value>) 	js/src/jsapi.cpp
28 	XUL 	mozilla::dom::EventHandlerNonNull::Call(JSContext*, JS::Handle<JS::Value>, nsDOMEvent&, mozilla::ErrorResult&) 	objdir-tb/x86_64/mozilla/dom/bindings/EventHandlerBinding.cpp
29 	XUL 	nsJSEventListener::HandleEvent(nsIDOMEvent*) 	objdir-tb/x86_64/mozilla/dist/include/mozilla/dom/EventHandlerBinding.h
30 	XUL 	nsEventListenerManager::HandleEventSubType(nsListenerStruct*, nsIDOMEvent*, mozilla::dom::EventTarget*) 	dom/events/nsEventListenerManager.cpp
31 	XUL 	nsEventListenerManager::HandleEventInternal(nsPresContext*, mozilla::WidgetEvent*, nsIDOMEvent**, mozilla::dom::EventTarget*, nsEventStatus*) 	dom/events/nsEventListenerManager.cpp
32 	XUL 	nsEventTargetChainItem::HandleEvent(nsEventChainPostVisitor&, ELMCreationDetector&) 	dom/events/nsEventListenerManager.h
33 	XUL 	nsEventTargetChainItem::HandleEventTargetChain(nsTArray<nsEventTargetChainItem>&, nsEventChainPostVisitor&, nsDispatchingCallback*, ELMCreationDetector&) 	dom/events/nsEventDispatcher.cpp
34 	XUL 	nsEventDispatcher::Dispatch(nsISupports*, nsPresContext*, mozilla::WidgetEvent*, nsIDOMEvent*, nsEventStatus*, nsDispatchingCallback*, nsCOMArray<mozilla::dom::EventTarget>*) 	dom/events/nsEventDispatcher.cpp
35 	XUL 	nsEventDispatcher::DispatchDOMEvent(nsISupports*, mozilla::WidgetEvent*, nsIDOMEvent*, nsPresContext*, nsEventStatus*) 	dom/events/nsEventDispatcher.cpp
36 	XUL 	nsINode::DispatchEvent(nsIDOMEvent*, bool*) 	content/base/src/nsINode.cpp
37 	XUL 	nsContentUtils::DispatchEvent(nsIDocument*, nsISupports*, nsAString_internal const&, bool, bool, bool, bool*) 	content/base/src/nsContentUtils.cpp
38 	XUL 	nsContentUtils::DispatchTrustedEvent(nsIDocument*, nsISupports*, nsAString_internal const&, bool, bool, bool*) 	content/base/src/nsContentUtils.cpp
39 	XUL 	nsAsyncDOMEvent::Run() 	dom/events/nsAsyncDOMEvent.cpp
40 	XUL 	nsContentUtils::AddScriptRunner(nsIRunnable*) 	content/base/src/nsContentUtils.cpp
41 	XUL 	nsTreeSelection::FireOnSelectHandler() 	layout/xul/tree/nsTreeSelection.cpp
42 	XUL 	nsTreeSelection::Select(int) 	layout/xul/tree/nsTreeSelection.cpp
43 	XUL 	NS_InvokeByIndex 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp
44 	XUL 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp
45 	XUL 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp
46 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/jscntxtinlines.h
47 	XUL 	Interpret 	js/src/vm/Interpreter.cpp
48 	XUL 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
49 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
50 	XUL 	js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value*, JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
51 	XUL 	JS::Call(JSContext*, JS::Value, JS::Value, unsigned int, JS::Value*, JS::MutableHandle<JS::Value>) 	js/src/jsapi.cpp
52 	XUL 	mozilla::dom::EventHandlerNonNull::Call(JSContext*, JS::Handle<JS::Value>, nsDOMEvent&, mozilla::ErrorResult&) 	objdir-tb/x86_64/mozilla/dom/bindings/EventHandlerBinding.cpp
53 	XUL 	nsJSEventListener::HandleEvent(nsIDOMEvent*) 	objdir-tb/x86_64/mozilla/dist/include/mozilla/dom/EventHandlerBinding.h
54 	XUL 	nsXBLPrototypeHandler::ExecuteHandler(mozilla::dom::EventTarget*, nsIDOMEvent*) 	dom/xbl/nsXBLPrototypeHandler.cpp
55 	XUL 	nsXBLEventHandler::HandleEvent(nsIDOMEvent*) 	dom/xbl/nsXBLEventHandler.cpp
56 	XUL 	nsEventListenerManager::HandleEventSubType(nsListenerStruct*, nsIDOMEvent*, mozilla::dom::EventTarget*) 	dom/events/nsEventListenerManager.cpp
57 	XUL 	nsEventListenerManager::HandleEventInternal(nsPresContext*, mozilla::WidgetEvent*, nsIDOMEvent**, mozilla::dom::EventTarget*, nsEventStatus*) 	dom/events/nsEventListenerManager.cpp
58 	XUL 	nsEventTargetChainItem::HandleEvent(nsEventChainPostVisitor&, ELMCreationDetector&) 	dom/events/nsEventListenerManager.h
59 	XUL 	nsEventTargetChainItem::HandleEventTargetChain(nsTArray<nsEventTargetChainItem>&, nsEventChainPostVisitor&, nsDispatchingCallback*, ELMCreationDetector&) 	dom/events/nsEventDispatcher.cpp
60 	XUL 	nsEventDispatcher::Dispatch(nsISupports*, nsPresContext*, mozilla::WidgetEvent*, nsIDOMEvent*, nsEventStatus*, nsDispatchingCallback*, nsCOMArray<mozilla::dom::EventTarget>*) 	dom/events/nsEventDispatcher.cpp
61 	XUL 	PresShell::HandleEventInternal(mozilla::WidgetEvent*, nsEventStatus*) 	layout/base/nsPresShell.cpp
62 	XUL 	PresShell::HandlePositionedEvent(nsIFrame*, mozilla::WidgetGUIEvent*, nsEventStatus*) 	layout/base/nsPresShell.cpp
63 	XUL 	PresShell::HandleEvent(nsIFrame*, mozilla::WidgetGUIEvent*, bool, nsEventStatus*) 	layout/base/nsPresShell.cpp
64 	XUL 	nsViewManager::DispatchEvent(mozilla::WidgetGUIEvent*, nsView*, nsEventStatus*) 	view/src/nsViewManager.cpp
65 	XUL 	nsView::HandleEvent(mozilla::WidgetGUIEvent*, bool) 	view/src/nsView.cpp
66 	XUL 	nsChildView::DispatchEvent(mozilla::WidgetGUIEvent*, nsEventStatus&) 	widget/cocoa/nsChildView.mm
67 	XUL 	nsChildView::DispatchWindowEvent(mozilla::WidgetGUIEvent&) 	widget/cocoa/nsChildView.mm
68 	XUL 	-[ChildView mouseDown:] 	widget/cocoa/nsChildView.mm
69 	AppKit 	AppKit@0x228d08 	
70 	libsystem_malloc.dylib 	libsystem_malloc.dylib@0x10b00 	
71 	libsystem_pthread.dylib 	libsystem_pthread.dylib@0x44a9 	
72 	libsystem_pthread.dylib 	libsystem_pthread.dylib@0x48f3 	
73 	AppKit 	AppKit@0xa51cf1 	
74 	Foundation 	Foundation@0x652a 	
75 	libobjc.A.dylib 	libobjc.A.dylib@0x5080 	
76 	AppKit 	AppKit@0x1c5620 	
77 	AppKit 	AppKit@0xa57c9b 	
78 	libobjc.A.dylib 	libobjc.A.dylib@0x5080 	
79 	XUL 	-[BaseWindow sendEvent:] 	widget/cocoa/nsCocoaWindow.mm
80 	XUL 	-[ToolbarWindow sendEvent:] 	widget/cocoa/nsCocoaWindow.mm
81 	AppKit 	AppKit@0x1c7744 	
82 	AppKit 	AppKit@0xa55828
(Reporter)

Comment 2

5 years ago
Only happens on one specific folder , joshua do you need .msf file or something similar ?
(Reporter)

Updated

5 years ago
Flags: needinfo?(Pidgeot18)

Comment 3

5 years ago
all crashes are linux and Mac, no windows.
Earliest crash of sig is 20140130030201 on linux bp-3e02159b-36ce-4158-9f55-1830c2140203

continuation of bug 961564?
Keywords: regression
Whiteboard: [dupeme?]
(Reporter)

Comment 4

5 years ago
I've removed the faulty msf for now. have it saved in case it might be helpful.

Comment 5

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #3)
> all crashes are linux and Mac, no windows.
> Earliest crash of sig is 20140130030201 on linux
> bp-3e02159b-36ce-4158-9f55-1830c2140203
> 
> continuation of bug 961564?

Could be. I finally collected a number of spam mails and crashed with today's build with bp-a510d1ad-30dc-4f0c-b35c-3050c2140206 while scrolling the folder which was the original symptom of bug 961564

Comment 6

5 years ago
Let's roll them together. Can always dedupe later.
Blocks: 961564
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [dupeme?]
Duplicate of bug: 961564
(In reply to Ludovic Hirlimann [:Usul] from comment #2)
> Only happens on one specific folder , joshua do you need .msf file or
> something similar ?

The useful query I need to know is if there are headers with the author entry missing.
Flags: needinfo?(Pidgeot18)
You need to log in before you can comment on or make changes to this bug.