configure does not accept -gtk options correctly.

VERIFIED DUPLICATE of bug 85186

Status

SeaMonkey
Build Config
--
minor
VERIFIED DUPLICATE of bug 85186
17 years ago
13 years ago

People

(Reporter: Addison Laurent, Assigned: cls)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.7 sun4u)
BuildID:    0.9.3

Running ./configure --with-gtk-exec=$HOME/93/gtk+-1.2.10 results in:

*** The gtk-config script installed by GTK could not be found.
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the

The exec prefix should be everything before gtk-config, not everything before,
except for bin/.


Reproducible: Always
Steps to Reproduce:
1. run configure with --with-gtk-exec=path to gtk-config
2.
3.

Actual Results:  *** The gtk-config script installed by GTK could not be found.
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.


Expected Results:  Not have inserted bin/ into the exec path.

Setting GTK_CONFIG works.  (Nice bit of documentation on that error)
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 85186 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.