Update bleach to 1.4 (and html5lib to 0.999)

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Code Quality
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: magopian, Assigned: magopian)

Tracking

Details

(Assignee)

Description

4 years ago
Bleach latest version is 1.4, and it uses a new major version (even though oddly numbered) of html5lib: 0.999.

This new html5lib version however deprecates the use of simpletree in favor of etree.

I know we're using html5lib and simpletree without going through bleach in a few places, so we'll need to change these too:

* amo.utils.clean_nl
* translations.utils.truncate
(Assignee)

Updated

4 years ago
Blocks: 846349
(Assignee)

Comment 1

4 years ago
Pull request: https://github.com/mozilla/zamboni/pull/1735
(Assignee)

Updated

4 years ago
Assignee: nobody → mathieu
(Assignee)

Comment 2

4 years ago
fixed in https://github.com/mozilla/zamboni/commit/ad79124f569daa7a35cc4a51f69c93cb8edce8d1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.