[B2G] No message displayed for "possibly" needing a reboot/ restart after changing language

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: Darren, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Description:
When changing a language the user may be required to restart/ reboot the device, to get all the string to properly changed to the selected language.

Repro Steps:
1. Load Buri to Build ID: 20140205004002
2. Open Settings App
3. Select Language
4. Tap on the drop-down
5. Select Any language

Actual Results:
The user is not prompted that they may be required to reboot/ restart to have all string appear in the selected language.

Expected Results:
A message is displayed letting the user know that a restart may be required to display all string.

Environmental Variables
Device: Buri v1.3 MOZ RIL
Build ID: 20140205004002
Gecko: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/2c7f237ba88b
Gaia: 3405c205cfb5625073b9db1e12ed5d173bdcc78c
Platform Version: 28.0
Base Build: v1.2-device.cfg

Notes:
If the reboot is not intended then all string will need to be displayed correctly or a bar to be display on the progress of updating the languages.
Does this reproduce on 1.1?
Keywords: qawanted
This issue reproduces on v1.1 as well.

v1.3 Environmental Variables:
Device: Buri v1.3 MOZ
BuildID: 20140206041207
Gaia: c5cb252e5d1aa45d14f3a2ea182e73e2271e4496
Gecko: adaf8883268e
Version: 18.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
Copy/paste error, here are the variables I was using.

v1.1 Environmental Variables:
Device: Buri v1.1 MOZ
BuildID: 20140206041207
Gaia: c5cb252e5d1aa45d14f3a2ea182e73e2271e4496
Gecko: adaf8883268e
Version: 18.0
Firmware Version: v1.2-device.cfg

Comment 4

2 years ago
developer can listen language change event now
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.