Unable to change regions in app compatibility page for a game

RESOLVED DUPLICATE of bug 968494

Status

Marketplace
Developer Pages
P1
normal
RESOLVED DUPLICATE of bug 968494
4 years ago
4 years ago

People

(Reporter: louisstow, Assigned: mat)

Tracking

({regression})

Avenir
2014-02-11
x86
Mac OS X
regression
Points:
---

Details

(Whiteboard: [see comment 5], URL)

(Reporter)

Description

4 years ago
When modifying the Regions and Listings, unchecking some regions will not be saved. Refresh the page and they are back to being checked.

I tested with https://marketplace.firefox.com/developers/app/metro-3/

1. Unchecked Spain, Greece, Hungary and Italy.
2. Save Changes
3. Refresh page and those regions will become checked
Odd, I can reproduce this on prod:
https://marketplace.firefox.com/developers/app/metro-3/payments/

but not on -dev:
https://marketplace-dev.allizom.org/developers/app/marketplace/payments/

Not sure what's up here? Caching? But this is super important.
Keywords: regression
Priority: -- → P1
Target Milestone: --- → 2014-02-04
Target Milestone: 2014-02-04 → 2014-02-11
(Assignee)

Comment 2

4 years ago
I can't reproduce this locally either ; When the issue happens, do you see the "Changes successfully saved" message at the top of the page ? Does that happen with other apps as well ?
(Reporter)

Comment 3

4 years ago
It says "Changes successfully saved". It is happening with other apps.
(Assignee)

Comment 4

4 years ago
Ok, I see it in production as well. Somehow it worked at least once when I tested, so a caching issue sounds likely. I'll try various strategies to reproduce it locally and on -dev tomorrow to come up with a fix.
Component: Admin Tools → Developer Pages
(Assignee)

Comment 5

4 years ago
I managed to reproduce it locally. It's because of the old region exclusion code for Games which ends up deleting the region exclusions we just created.

STR:
- Upload an app, put it in the "Games" category
- Set up content ratings - I answered "No" to every question on the IARC form
- Go to devhub compatibility page, try to uncheck some regions

Expected:
- You get the "Changes successfully saved" message and the regions you unchecked appear, well, unchecked.

Actual:
- You get the "changes successfully saved" message but the regions you unchecked are still checked

This will get fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=968494 but I'm not marking as duplicate just yet as I'd prefer to wait for this bug to be fixed and then make sure there is not something else going on.
(Assignee)

Updated

4 years ago
Summary: Region listing not saving → Unable to change regions in app compatibility page for a game
Whiteboard: [see comment 5]
(Assignee)

Updated

4 years ago
Assignee: nobody → mpillard
(Assignee)

Comment 6

4 years ago
Fixing bug 968494 did fix this bug as well, I just checked on -dev.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 968494
You need to log in before you can comment on or make changes to this bug.