Get a screenshot in the build log when the build times out

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
4 years ago
15 days ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
This will help us decipher mysterious try failures such as the one I'm seeing in bug 944800.  We current take a screenshot when we get a test timeout, it would be nice to do the same for build timeouts as well.
This may be harder than believed on the surface, fwiw. (at least right now).

The test harness is what takes the screenshot when a test times out, while a build timeout tends to be buildbot killing whatever procs have run already, and after it does so future steps don't know for sure what happened in previous steps, if they succeeded or failed, or whatever else may have happened.
There's a way to prevent that missing DLL popup box from happening on windows, perhaps that's the right fix?
(Reporter)

Comment 3

4 years ago
(In reply to comment #2)
> There's a way to prevent that missing DLL popup box from happening on windows,
> perhaps that's the right fix?

How would you do that?  (And yes, we should definitely do that!)
Q, any ideas?
Flags: needinfo?(q)

Comment 5

4 years ago
Looking at the attached bug the primary issue is fixed. However, assuming WER is already off it may be possible to have the debugger report to event viewer instead of using a popup in the future.
Flags: needinfo?(q)
Duplicate of this bug: 1178243
Summary: Get a screenshot in the build log when the test times out → Get a screenshot in the build log when the build times out
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Updated

15 days ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.