can't view eval-ed JavaScript source for www.gwtproject.org

RESOLVED DUPLICATE of bug 865313

Status

RESOLVED DUPLICATE of bug 865313
5 years ago
3 months ago

People

(Reporter: skybrian, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(firefox27 wontfix, firefox28 unaffected, firefox29 unaffected, firefox30 unaffected)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.102 Safari/537.36

Steps to reproduce:

1. Visit www.gwtproject.org
2. Open the debugger
3. In settings, uncheck "Show original sources"
4. reload the page



Actual results:

The debugger shows four files:
ga.js
www.gwtproject.org/
6788...E08E.cache.js
gwtproject.nocache.js

If you click on the cache.js file, the debugger displays "Loading..." and hangs for a long time, but eventually displays the file. However, it's not very useful because we'd like to see the resulting JavaScript after eval().


Expected results:

In the Chrome debugger for the same web page, the eval-ed JavaScript shows up under "(no domain)" with name "gwtproject-0.js", which is the name given in the comment at the end of the eval-ed JavaScript.
WFM with latest Nightly on Ubuntu 13.10 32-bit.

Could you please try the following :

1) try this with a clean profile: http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

2) running in Safe mode: http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Component: Untriaged → Developer Tools: Debugger
Luckily this bug only exists in the release channel, but unfortunately it is too late for us to fix it there. We generally don't ship hotfixes for devtools-only bugs. 

You could use Firefox Beta for the next few weeks until Firefox 28 is released. It's sad that we didn't fix that bug in time to uplift the fix to Firefox 27.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
status-firefox27: --- → wontfix
status-firefox28: --- → unaffected
status-firefox29: --- → unaffected
status-firefox30: --- → unaffected
Resolution: --- → WONTFIX
(Reporter)

Comment 3

5 years ago
I just tried it out using nightly in safe mode, with a clean profile, and the behavior is the same as Firefox 27. I see the same four files as in the original report, and no eval-ed code.

If you think it works for you, please tell me where to find the eval-ed JavaScript in the debugger. (What's the name of the file?) Otherwise I assume you didn't understand the bug report and I'll have to clarify.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Version: 27 Branch → Trunk
I think this is just a dupe of bug 865313 because we don't support debugging eval'd scripts at all right now. There are a handfull of cases where it kind of barely works, but those cases are accidental and not properly supported.
(Reporter)

Comment 5

5 years ago
Okay fair enough.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 865313
Sorry, I thought you expected to see the original, pre-sourcemap files, which should work. Unfortunately dynamic eval scripts don't work properly yet, as Nick said.

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.