Closed Bug 968684 Opened 6 years ago Closed 6 years ago

Add Makefile for homescreen app

Categories

(Firefox OS Graveyard :: Gaia::Build, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: yurenju, Assigned: yurenju)

References

Details

Attachments

(1 file)

add a makefile for homescreen and migrate homescreen related code from applications-data.js and webapp-zip.js
Assignee: nobody → yurenju.mozilla
WIP: https://github.com/yurenju/gaia/commit/5ec4388b68da31519175f1a69bf0daea46dd7365

since homescreen use webapp-manifests.js to get all manifests of apps, I'm going to refactor communications app first because comm. app use webapp-manifests.js to get their own manifest file.
high resolution icon doesn't apply to homescreen when first launch, we should fix it for build script part.
last one for app-makefile refactoring!

I also filed a follow up bug 972755 to store preload apps data from DISTRIBUTION_DIR/temp to build_stage/preload-app-data/.
Attachment #8376114 - Flags: review?(timdream)
Comment on attachment 8376114 [details] [review]
github PR: https://github.com/mozilla-b2g/gaia/pull/16283

Discussed offline.

Damn you svoperapps!
Attachment #8376114 - Flags: review?(timdream)
Comment on attachment 8376114 [details] [review]
github PR: https://github.com/mozilla-b2g/gaia/pull/16283

refactored this refactoring code \o/

I commited for each your comment on github, those will be squashed to one commit if get r+
Attachment #8376114 - Flags: review?(timdream)
Comment on attachment 8376114 [details] [review]
github PR: https://github.com/mozilla-b2g/gaia/pull/16283

Please manually confirm both old script and new script passes the test, before merging the pull request.

Thank you, nice work!
Attachment #8376114 - Flags: review?(timdream) → review+
waiting for travis-ci.
Blocks: 975964
Duplicate of this bug: 972755
Component: Gaia → Gaia::Build
You need to log in before you can comment on or make changes to this bug.