Moz crashes when clicking a certain combination of pages on orf.at

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: Michael Raidel, Assigned: edburns)

Tracking

({crash, stackwanted})

Trunk
x86
Windows ME
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I hope this is no duplicate of some Java-related crashes (it seems to be related
to #89649) but I think the behaviour is a unique one:

The browser crashes (without calling talkback) when going to www.orf.at(1) then
clicking on one of the articles(2), next clicking on the link "futurezone" at
the bottom of the page(3). (In fact there is the typical WinME popup:
"Application caused an fault..". You still can use Mozilla [except the
Java-Applets], but the popup is always in the front. If I click on "Close", all
Mozilla windows and the application itself are closed.) There is a little
Java-Applet on the top of the Article Page(2) which I think causes the error
when changing to the third page (futurezone). This happens not with all of the
Article-Pages (50% or so), but an Article-Page which triggers the error,
triggers it every time (when changing to the third page). This happened
approximately 30 times to me. It happened with 0.9.1, 0.9.2 and 0.9.3 (I started
with 0.9.1), so I didn't try a nightly build until now. (stupid downloadlimits.. ;-)

greetings, Michael

ps: because this seems to be relevant in bug # 89649 too: I use an english
Mozilla on a german WinME.

Here is the windows-error-message:

MOZILLA verursachte einen Fehler durch eine ung├╝ltige Seite
in Modul AWT.DLL bei 018f:5006f176.
Register:
EAX=106452ac CS=018f EIP=5006f176 EFLGS=00010206
EBX=10403f8c SS=0197 ESP=0877f9ec EBP=00000244
ECX=00000244 DS=0197 ESI=041c6664 FS=5eb7
EDX=cdd1441a ES=0197 EDI=106452ac GS=0000
Bytes bei CS:EIP:
8b 0f 83 c7 04 8b d9 88 4a fe c1 eb 08 c1 e9 10 
Stapelwerte:
041c6610 182c6f90 0877fa94 182c6f58 00000244 cdd14418 10403f8c ccbfc000 00000000
00002b28 000003e8 000045e4 00000001 00000003 00000001 00000000 

Some Java-Console output (maybe some programmer will need this info)
Dump classloader list ...
    codebase=http://www.orf.at/orfon/, zombie=false, cache=true,
info=sun.plugin.ClassLoaderInfo@61a408
Done. Memory: 3344K  Free: 1371K  (40%) ... completed. Dump system properties ...
---------------------------------------------------
acl.read = +
acl.read.default = 
acl.write = +
acl.write.default = 
application.home = C:\PROGRA~1\JAVASOFT\JRE\13~1.0_0
awt.toolkit = sun.awt.windows.WToolkit
bridge.home = C:\PROGRA~1\JAVASOFT\JRE\13~1.0_0
browser = sun.plugin
browser.vendor = Sun Microsystems, Inc.
browser.version = 1.1
file.encoding = Cp1252
file.encoding.pkg = sun.io
file.separator = \
file.separator.applet = true
http.agent = Mozilla/5.0 (Windows 98)
java.awt.fonts = 
java.awt.graphicsenv = sun.awt.Win32GraphicsEnvironment
java.awt.printerjob = sun.awt.windows.WPrinterJob
java.class.path = .
java.class.version = 47.0
java.class.version.applet = true
java.ext.dirs = C:\PROGRAMME\JAVASOFT\JRE\1.3.0_01\lib\ext
java.home = C:\PROGRA~1\JAVASOFT\JRE\13~1.0_0
java.io.tmpdir = C:\WINDOWS\TEMP\
java.library.path =
C:\PROGRAMME\MOZILLA.ORG\MOZILLA;.;C:\WINDOWS\SYSTEM;C:\WINDOWS;C:\Programme\mozilla.org\Mozilla\;C:\WINDOWS;C:\WINDOWS\COMMAND;C:\PROGRA~1\NETWOR~1\PGP;C:\PROGRA~1\ULTRAE~1
java.protocol.handler.pkgs = sun.plugin.protocol.jdk12
java.runtime.name = Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version = 1.3.0_01
java.specification.name = Java Platform API Specification
java.specification.vendor = Sun Microsystems Inc.
java.specification.version = 1.3
java.vendor = Sun Microsystems Inc.
java.vendor.applet = true
java.vendor.url = http://java.sun.com/
java.vendor.url.applet = true
java.vendor.url.bug = http://java.sun.com/cgi-bin/bugreport.cgi
java.version = 1.3.0_01
java.version.applet = true
java.vm.info = mixed mode
java.vm.name = Java HotSpot(TM) Client VM
java.vm.specification.name = Java Virtual Machine Specification
java.vm.specification.vendor = Sun Microsystems Inc.
java.vm.specification.version = 1.0
java.vm.vendor = Sun Microsystems Inc.
java.vm.version = 1.3.0_01
javaplugin.maxHeapSize = 128m
javaplugin.nodotversion = 130_01
javaplugin.proxy.config.type = auto
javaplugin.version = 1.3.0_01
line.separator = \r\n
line.separator.applet = true
mozilla.workaround = true
os.arch = x86
os.arch.applet = true
os.name = Windows 98
os.name.applet = true
os.version = 4.90
os.version.applet = true
package.restrict.access.netscape = false
package.restrict.access.sun = true
package.restrict.definition.java = true
package.restrict.definition.netscape = true
package.restrict.definition.sun = true
path.separator = ;
path.separator.applet = true
sun.boot.class.path =
C:\PROGRAMME\JAVASOFT\JRE\1.3.0_01\lib\rt.jar;C:\PROGRAMME\JAVASOFT\JRE\1.3.0_01\lib\i18n.jar;C:\PROGRAMME\JAVASOFT\JRE\1.3.0_01\lib\sunrsasign.jar;C:\PROGRAMME\JAVASOFT\JRE\1.3.0_01\classes;C:\PROGRA~1\JAVASOFT\JRE\13~1.0_0\lib\jaws.jar;C:\PROGRA~1\JAVASOFT\JRE\13~1.0_0\lib\tools.jar;C:\PROGRA~1\JAVASOFT\JRE\13~1.0_0\lib\plugprov.jar;C:\PROGRA~1\JAVASOFT\JRE\13~1.0_0\lib\sunrsasign.jar
sun.boot.library.path = C:\PROGRAMME\JAVASOFT\JRE\1.3.0_01\bin
sun.cpu.endian = little
sun.cpu.isalist = pentium i486 i386
sun.io.unicode.encoding = UnicodeLittle
trustProxy = true
user.dir = C:\PROGRAMME\MOZILLA.ORG\MOZILLA
user.home = C:\WINDOWS
user.language = de
user.name = mig
user.region = AT
user.timezone = Europe/Berlin

Updated

16 years ago
Keywords: crash, stackwanted

Comment 1

16 years ago
->OJI
Assignee: asa → edburns
Status: UNCONFIRMED → NEW
Component: Browser-General → OJI
Ever confirmed: true
QA Contact: doronr → pmac

Comment 2

16 years ago
Worksforme Build ID: 2002042510 (0.9.9+) trunk Windows 98.

Reporter, could you install 0.9.9 and Sun Java JRE 1.4 and see if the problem 
still happens?
Severity: major → critical
(Reporter)

Comment 3

16 years ago
No problem anymore with JRE 1.3.1 and Mozilla 1.0 RC1!

I have tested my old OS-configuration (WinME) with JRE 1.3.1 and Mozilla 1.0
RC1. Although I really tried to, I couldn't crash Mozilla anymore! ;-) This one
seems to be fixed...

Comment 4

16 years ago
Excellent! Thanks. Resolving as worksforme.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.