A lot of empty space around comments

RESOLVED DUPLICATE of bug 332207

Status

()

Bugzilla
User Interface
RESOLVED DUPLICATE of bug 332207
4 years ago
2 years ago

People

(Reporter: mistria, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131206152142

Steps to reproduce:

Looking at a bug and its comments


Actual results:

Half of screen width is empty, many comments lines are wrapped.


Expected results:

It would make more sense IMO to let comment occupy the whole available space. It would allow to have some mail-like formatting, adoption markdown or asciidoc conventions to better organize the comment.

Also, when pasting code, lines are wrapped because of the lack of size. It reduces the readability.

Comment 1

4 years ago
See also bug 641913, which is maybe what you want.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 332207
(Reporter)

Comment 2

4 years ago
I'm not really asking for a checkbox, I'm more asking for fixing the CSS file to allow comments to take the full width available.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

4 years ago
The bigger the screen width, the more of a PITA to read such long linesand not get lost finding the next line on the left. This proposal is against usability / readability.
(Reporter)

Comment 4

4 years ago
So you also believe that email client and wikis for example are bad usability/readability ?

Comment 5

4 years ago
I don't know which software you use, but my email client wraps (plain text) message content at 75 chars, and MediaWiki recently started setting #bodyContent to "max-width: 715px" as part of BetaFeatures/Typography Refresh. Here are some links that I stole from my co-worker:
http://baymard.com/blog/line-length-readability
http://webtypography.net/Rhythm_and_Proportion/Horizontal_Motion/2.1.2/
https://ux.stackexchange.com/questions/3618/ideal-column-width-for-paragraphs-online
https://www.fonts.com/content/learning/fontology/level-2/text-typography/length-column-width
(Reporter)

Comment 6

4 years ago
Ok, thanks for these links.
The issue is that it's quite difficult to make long text or code easily readable in Bugzilla comments. But I guess having ability to have rich text and to force some (code) lines to not wrap would be a valid workaround.
FYI, this request comes as an "escalation" of this request to Eclipse Bugzilla: https://bugs.eclipse.org/bugs/show_bug.cgi?id=391211 , where comments width is 500px on my screen. 715px like MediaWiki would already be better.

Out of Bugzilla, I use Jira, which I prefer probably because of it's ability to have rich texts, making it easier to have debates. The comments width on Jira seems to be 1050px on my screen, and I personally find it comfortable.

Updated

4 years ago

Comment 7

2 years ago
This is really a dupe of bug 332207, which has already been marked as WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 332207
You need to log in before you can comment on or make changes to this bug.