Deletion of sub-selection of Substring(0, x) in url bar clears the entire thing.

RESOLVED INVALID

Status

()

Firefox
Address Bar
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: sirintellegence, Unassigned)

Tracking

29 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

Create a selection in the url bar from some-where (anywhere but the end) to the start and press back-space


Actual results:

The entire url bar is cleared


Expected results:

Only the selection is deleted
(Reporter)

Updated

4 years ago
Component: Untriaged → Location Bar
(Reporter)

Updated

4 years ago
Summary: Deletion of sub-selection of Substring(0, x) clears the entire thing. → Deletion of sub-selection of Substring(0, x) in url bar clears the entire thing.
(Reporter)

Comment 1

4 years ago
This appears to be fixed in the current nightly.  When will the update for this be released?
(Reporter)

Updated

4 years ago
Version: 27 Branch → 29 Branch
(Reporter)

Comment 2

4 years ago
This appears to still be an issue in the current version of Firefox
(Reporter)

Comment 3

4 years ago
Do I need to clarify this?
I'm currently unable to reproduce this bug on Nightly 34.0a1 (2014-09-02) using Windows 7 64-bit.

Reporter, are you still seeing this issue on your end?
Flags: needinfo?(sirintellegence)
(Reporter)

Comment 5

4 years ago
It seems to work correctly in the latest nightly, but it is still broken in the latest stable (32.0)
Flags: needinfo?(sirintellegence)
(In reply to sirintellegence from comment #5)
> It seems to work correctly in the latest nightly, but it is still broken in
> the latest stable (32.0)
Thank you for the prompt reply, but this is working properly on my end - tested with both Firefox 32.0 and Aurora 33.0a2 (2014-09-02).

Could you please let me know if any of the following methods are fixing the problem?
1. Try to reproduce the bug on a new (clean) profile.
- see: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
2. Try to reproduce the bug in Safe Mode.
- see: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(sirintellegence)
(Reporter)

Comment 7

4 years ago
Hmm.... a semi-clean profile works fine... I'll check to see what extension it is...
Flags: needinfo?(sirintellegence)
(Reporter)

Comment 8

4 years ago
Addon responsible is Fastest Search 3.31, I'll go submit a bug report to them.
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.