Closed Bug 968924 Opened 6 years ago Closed 6 years ago

Add shapes to network status bubbles

Categories

(DevTools :: Netmonitor, defect)

x86
macOS
defect
Not set

Tracking

(firefox29- verified, firefox30 verified)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 - verified
firefox30 --- verified

People

(Reporter: rcampbell, Assigned: rcampbell)

References

Details

Attachments

(2 files)

Currently the netmonitor status bubbles are all colored circles. We should add some variety to those to make them easier to distinguish.

I'm thinking of adding circles, triangles, squares, and octagons.
Can we just add the status code? It's very frustrating for me as a color blind person. Shapes would help some, but I really just want the status code.
that's why I'm adding shapes!
Attached patch shapesSplinter Review
Assignee: nobody → rcampbell
Status: NEW → ASSIGNED
Attached image Screen Shot.png
not pictured: the diamond! (500 - server errors)
Attachment #8371697 - Flags: review?(vporof)
Attachment #8371697 - Flags: review?(vporof) → review+
Keywords: checkin-needed
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/47f971e754b6
Keywords: checkin-needed
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/47f971e754b6
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Comment on attachment 8371697 [details] [diff] [review]
shapes

[Approval Request Comment]
Bug caused by (feature/regressing bug #): circles
User impact if declined: users will be denied alternative polygons
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): negligible. Style changes only.
String or IDL/UUID changes made by this patch: nada
Attachment #8371697 - Flags: approval-mozilla-aurora?
Attachment #8371697 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 892039
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.