Profiles disappear after upgrading from Mozilla 0.9.1 to 0.9.3

VERIFIED INVALID

Status

Core Graveyard
Profile: BackEnd
--
blocker
VERIFIED INVALID
16 years ago
2 years ago

People

(Reporter: Wim Godden, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I downloaded the Windows 0.9.3 version (with Talkback) and installed it 
(complete install) over the current installation of 0.9.1.
It automatically started Mozilla, but gave me no profiles in the profile box. 
When I click in the (empty) profile box, Mozilla crashes (DrWatson process 
begins to run, but Talkback doesn't). So I've seem to have lost all my profiles 
now, including mail, etc.

Comment 1

16 years ago
This could be a profile manager problem. Howmany profiles did you have when
working with 0.9.1 version..?

There have been some changes between versions in the profilemanager code. But
it's hard to imagine anything causing problems you have mentioned.

We do not remove anything during upgrades. So, I am sure you have all your mail
and data right there on the disk. The issue now is to bring them to life.

Reassigning to Conrad.
Assignee: racham → ccarlen
Component: Profile Migration → Profile Manager BackEnd
(Reporter)

Comment 2

16 years ago
I had 4 profiles active in the 0.9.1 version. However, I have no idea where to 
find them or how to get them back to working...
(Assignee)

Comment 3

16 years ago
    The location and format of the profile registry (the list of profiles) has
not changed between those two versions and this is the first I've heard of this.
    Since the profile dialog came up but was empty the first time the installer
launched the app, it would suggest that more than one profile was read from the
registry. If the registry was not found or was empty, the profile mgr would make
a new default profile without showing the dialog unless you had 4.x profiles to
be migrated. In any case, an empty profile mgr dialog should not be possible.
Has anything else changed on your machine since you had your 4 profiles working
with 0.9.1? Are you logging into Windows as the same user?
(Reporter)

Comment 4

16 years ago
There have been no changes at all in my system. In fact, I downloaded the .exe 
file with 0.9.1, then closed it and ran the .exe.
Reporter: 
Please never install a new build over an older one.
Can you try it with a clean install in a fresh directory ?
(Reporter)

Comment 6

16 years ago
I could, but I'd like to get my profiles back as well...
Marking WFM as per Matti's comments on installing over old builds. Reporter: If
you can reproduce this, please reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

16 years ago
So you're marking it 'resolved', but you want me to reproduce it ?
Well, fact is I still can't work with my profiles. I've lost my mail, my 
bookmarks, etc, because I still can't start Mozilla.
Nowhere during the installation I noticed a warning about not installing a new 
build over an old one. I consider this a very normal action, which should work 
for any software.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
wim@godden.net: You should read the release notes and you can read there that 
you should not install a newer build over an older one.
"http://www.mozilla.org/releases/mozilla0.9.3/"
(Reporter)

Comment 10

16 years ago
QUOTE : Install into a new empty directory. Installing on top of previously 
installed builds may cause problems. 

OK, it's there... but you can't expect every user of Mozilla to read everything. 
Most users simply download and run the .exe-file, as should be possible. It 
works fine for 99.99% of all programs...

Comment 11

16 years ago
this product is still in development thus the reason for the warnings. There is
not much we can do if people dont read the directions. Marking INvalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 12

16 years ago
Well, ok, any ideas how I can get my profiles back ?

Comment 13

16 years ago
I gave Wim the following suggestion:
So rename the Mozilla folder
> restart with mozilla -profilemanager
> create a profile (same name of one previous if you wish)
> use the profile so that some data is created (not much- maybe one bookmark)
> exit Mozilla
> go to renamed Mozilla folder and copy the list of files in the old profiles 
.slt
directoy
> to the slt directory in the new Mozilla\newprofile\newslt directory
> rerun mozilla and verify you have old profile information in the newly created
profile

from Wim
I had to remove Mozilla and then follow the steps you told me to... it
works fine now !

not sure if this is invalid- somehow the registry got corrupted, but there is a 
workaround.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.