Closed Bug 969060 Opened 6 years ago Closed 6 years ago

Disabling dynamic panel set as default will put default panel in ambiguous state

Categories

(Firefox for Android :: Awesomescreen, defect, P1)

All
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox30 --- fixed

People

(Reporter: mcomella, Assigned: lucasr)

References

(Blocks 1 open bug)

Details

1) Install a HomePanel addon (such as [1])
2) Click the overflow button: Settings -> Customize -> Home
3) Set the installed panel as the default
4) Go back to about:home
5) Click the overflow button: Tools -> Add-ons
6) Click the installed addon, then select Disable
7) Go back to about:home
8) Click the overflow button: Settings -> Customize -> Home

Expected: Some other panel is set at the default
Actual: The "default" subtext is missing.

Re-enabling the addons does not restore the default subtext.

[1]: https://github.com/mcomella/fennec_rss/tree/no_default
Priority: -- → P1
We need to consolidate a central API for changing the HomeConfig state in a way that ensures we'll always end with a valid HomeConfig state no matter where the change is triggered from. For instance, we need the same code for ensuring a new default panel when one a hidden/removed both in the settings UI and in HomeConfigInvalidator.
Assignee: nobody → lucasr.at.mozilla
I think we need bug 967742 in order to implement a proper fix for this bug.
FYI: this bug is fixed by the patch in bug 967742.
Depends on: 967742
Bug 967742 has landed and fixes this bug. Closing.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
On Firefox 30 Beta 4 using Alcatel One Touch (Android 4.1.2) and  Nexus 10 (Android 4.4.2)  no other panel is set as the default, the subtext is missing.
Please file a new bug.
On Firefox 30 Beta 6 using Alcatel One Touch (Android 4.1.2) and  Nexus 4 (Android 4.4.2) I'm not able to reproduce this, the "default" subtext is present under the History panel.
Setting P1 hub bugs to block hub v1 EPIC bug (targeting fx30 release).

Filter on epic-hub-bugs.
Blocks: 1014025
You need to log in before you can comment on or make changes to this bug.