Closed Bug 969082 Opened 6 years ago Closed 6 years ago

[B2G][Dialer] Tapping on Rocketbar while in a phone call will make Task Manager display over Dialer App

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED DUPLICATE of bug 1036642
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: tnguyen, Unassigned)

References

Details

(Keywords: uiwanted)

Attachments

(3 files)

Attached image screenshot
Description:
Tapping on the "Search" of Rocketbar will bring up the Task Manager overlapping the Dialer App. The user is able to navigate through the Task Manager while it's displayed.

Repro Steps:
1) Updated Buri to BuildID: 20140206040203
2) Navigate to Dialer App
3) Make a call to another device 
4) While in a phone call, tap on the Rocketbar

Actual Result:
Rocketbar is displayed overlapping the Dialer App

Expected Result:
Rocketbar doesn't display overlapping the Dialer App

Environmental Variables:
Device: Buri Master M-C mozRIL
BuildID: 20140206040203
Gaia: ac8a273809b5b160554e616bc5ef2d6fa026ce0e
Gecko: 1e9f169c9715
Version: 30.0a1
v1.2-device.cfg

Attached: screenshot
Component: Gaia::Dialer → Gaia::Search
There is definitely a problem, but I'm not sure if the expected result is correct. There are many times where I'm on a phone call/conference and want to open up a browser to search the web. I would actually say that the call should be active, and go into task manager mode so I can access other pages, or the web at my leisure. Why should we artificially restrict the usefulness of the phone while on a call?

Looping in peter and francis here to see what the requirements really should be.
Flags: needinfo?(pdolanjski)
Flags: needinfo?(fdjabri)
(In reply to Kevin Grandon :kgrandon from comment #1)
> There is definitely a problem, but I'm not sure if the expected result is
> correct. There are many times where I'm on a phone call/conference and want
> to open up a browser to search the web. I would actually say that the call
> should be active, and go into task manager mode so I can access other pages,
> or the web at my leisure. Why should we artificially restrict the usefulness
> of the phone while on a call?
> 
> Looping in peter and francis here to see what the requirements really should
> be.

I don't think that's what the bug is arguing for. The bug is talking about the fact that the task manager is rendering on top of the in call UI, which looks awkward. They aren't questioning the fact about whether the rocketbar can be used while within a call.
(In reply to Jason Smith [:jsmith] from comment #2)
> 
> I don't think that's what the bug is arguing for. The bug is talking about
> the fact that the task manager is rendering on top of the in call UI, which
> looks awkward. They aren't questioning the fact about whether the rocketbar
> can be used while within a call.

I suppose the expected result wasn't clear to me then. In any case, this needs some thought/design as it's likely that rocketbar needs to be accessible in a way that does not conflict with the call banner at the top of the screen.
Keywords: uiwanted
Francis, this is definitely your call - what is your recommendation for rendering of task manager over the call UI?
Flags: needinfo?(pdolanjski)
Duplicate of this bug: 973539
Attached image screenshot2
This issue happens in other areas as well. I was able to get the task manager view to be displayed over the message asking user to share location. Should I open a separate bug for this new issue? I've attached a screenshot to represent the new found issue.
Passing over to Rob as this is related to Notifications.
Flags: needinfo?(fdjabri) → needinfo?(rmacdonald)
In this instance the dialer should show up in the task manager just as any other app. It should not show in the background as per the screen shots. So this is definitely a bug. 

In terms of showing an active call (or webrtc call), I will be working on a solution for 2.1 and it most likely will be in the notification tray. I don't believe that impacts this issue but feel free to NI me if it does.

Thanks!
Flags: needinfo?(rmacdonald)
It goes back to the dialer now when tapping on the rocketbar, which is odd behavior.  When tapping again on the home button for 2.1, you get a blank screen.  for 2.0 you get the homescreen.  I filed a separate bug for 2.1: bug 1039760
I think there's a behavior change in 2.0; I think we should close this bug and create a new one based on the dialer screen appearing instead of going to search for 2.0
Flags: needinfo?(tnguyen)
Keywords: qawanted
This should be fixed by bug 1036642 once it lands on 2.0
On the original build that this bug was filed under, there's a 'rocketbar' on top of each app, and it's located on the left of status bar. When tapping on it, it goes to a search screen but I can't actually search for anything because keyboard doesn't get invoked. So I'm unsure of its functionality.

I'd say this bug is obsolete because such rocketbar that displays on top of each app is non existent in current branches.

I did test on latest master Buri and 2.0 Flame and try to accessing Rocketbar while in a call by pressing Home button to go back to Homescreen first and nothing seemed out of place in this scenario.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(tnguyen) → needinfo?(jmitchell)
Keywords: qawanted
bug 1036642  was pushed a couple of days ago in 2.0  I am duping this bug to bug 1036642 because that fixed the bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1036642
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Hi all,
    This bug has been successfully verified on Flame 2.1&2.0.
    See attachment: verified_v2.1.mp4.
    Reproducing rate: 0/5

Flame 2.0 build:
Gaia-Rev        f9d6e3d83c3922e9399a6c27f5ce4cdd27bdfd05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/45112935086f
Build-ID        20141126000203
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.032754
FW-Date         Wed Nov 26 03:28:05 EST 2014
Bootloader      L1TC00011880

Flame 2.1 build:
Gaia-Rev        db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/211eae88f119
Build-ID        20141126001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.033519
FW-Date         Wed Nov 26 03:35:30 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.