Closed Bug 969125 Opened 6 years ago Closed 6 years ago

[Linux] Sync toolbar button disappears during synchronization

Categories

(Firefox :: Theme, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: veeti.paananen, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3+])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140204030201

Steps to reproduce:

Add a bookmark


Actual results:

The sync button in the toolbar disappears completely and distracts me


Expected results:

The button should show some sort of slight progress animation instead
Summary: Sync toolbar button disappears during synchronization → [Linux] Sync toolbar button disappears during synchronization
Whiteboard: [Australis:P3]
Component: Untriaged → Theme
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Australis:P3] → [Australis:P3+]
Actually, the active sync icon on Linux that we have in the tree is too big. Michael, could you provide an asset for the toolbar icon on Linux for the active sync state? Or should we just be using the same stuff as for the panel, only smaller? (are those assets on bug 940844 ?)
Flags: needinfo?(mmaslaney)
Yes, the toolbar glyphs (18x18 pixels) are attached in bug 940844
Flags: needinfo?(mmaslaney)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
I'll take care of updating the other platforms' icons in bug 940844.
Attachment #8375015 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8375015 [details] [diff] [review]
Patch

Review of attachment 8375015 [details] [diff] [review]:
-----------------------------------------------------------------

This is meant to animate. I guess we can take this here to avoid the current mess, and fix the animation as well as the other platforms in the other bug? For that, r=me.
Attachment #8375015 - Flags: review?(gijskruitbosch+bugs) → review+
Backed out the previous push since the commit message was wrong,
https://hg.mozilla.org/integration/fx-team/rev/2305e1d0e8d0

And relanded with the correct commit message,
https://hg.mozilla.org/integration/fx-team/rev/5add27ecfcb3
https://hg.mozilla.org/mozilla-central/rev/5add27ecfcb3
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8375015 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression from bug 874674
User impact if declined: missing icon when sync'ing
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8375015 - Flags: approval-mozilla-aurora?
Attachment #8375015 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: cornel.ionce
Reproduced with Nightly from 2014-02-04.

Verified as fixed with latest Aurora (Build ID: 20140314004001) and Nightly (Build ID: 20140314030202):
Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.