make test-perf fail to collect mem stats

RESOLVED FIXED

Status

Firefox OS
Gaia::PerformanceTest
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: hub, Assigned: hub)

Tracking

({perf})

unspecified
x86_64
Linux

Firefox Tracking Flags

(b2g-v1.3T fixed)

Details

(Whiteboard: [c=automation p=1 s= u=])

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
julienw
: review+
Details | Review | Splinter Review
(Assignee)

Description

4 years ago
Since very recently, collecting memory stats on buri/hamachi files.

b2g-info output starts with "Expected to read 4 fields from fscanf(/proc/2942//stat), but got 2." which is not expected. I can't figure why but we could make the meminfo.js code deal with it better.
(Assignee)

Updated

4 years ago
Assignee: nobody → hub
Keywords: perf
Whiteboard: [c=automation p=1 s= u=]
(Assignee)

Comment 1

4 years ago
Ok, this is caused by not having this revision of gonk-misc on my buri:

ac1b69cc36ce8cf64c8ce585826e7a940b349072

I think the simple solution is to actually update it on my device.
(Assignee)

Comment 2

4 years ago
Created attachment 8372054 [details] [review]
Pull request

I think that even though I need to update b2g-info on my device, we can still have an error message pop out. Make this more robust.
Attachment #8372054 - Flags: review?(felash)
Comment on attachment 8372054 [details] [review]
Pull request

I agree with the reasoning, but I think we can do a more reliable function. See github :)
Attachment #8372054 - Flags: review?(felash)
(Assignee)

Updated

4 years ago
Priority: -- → P1
See Also: → bug 971657
(Assignee)

Comment 4

4 years ago
Comment on attachment 8372054 [details] [review]
Pull request

Updated the pull request.
Attachment #8372054 - Flags: review?(felash)
(Assignee)

Updated

4 years ago
Component: Gaia → Gaia::PerformanceTest
Comment on attachment 8372054 [details] [review]
Pull request

r=me with nits for the commit "Rewrite the parser to be more permissive and foresee more changes."
Attachment #8372054 - Flags: review?(felash) → review+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.