[dev] "Oops ..." page displayed when trying to save payment options for a paid app

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: RobertC, Assigned: davidbgk)

Tracking

Avenir
Points:
---

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:
1.Go to MP-dev devhub and open one of your paid apps
2.Go to Compatibility&Payments option
3.Select an existing payment account and click save

Expected result:
Changes are successfully saved

Actual result:
"Oops..." page is displayed
(Reporter)

Updated

5 years ago
Whiteboard: [fromAutomation]
(Reporter)

Updated

5 years ago
Summary: [dev] "Oops ..." page dispalyed when trying to save payment options for a hosted paid app → [dev] "Oops ..." page displayed when trying to save payment options for a hosted paid app

Comment 1

5 years ago
This is reproducible for packaged apps too.
Summary: [dev] "Oops ..." page displayed when trying to save payment options for a hosted paid app → [dev] "Oops ..." page displayed when trying to save payment options for a paid app

Comment 2

5 years ago
We moved to reference implementation on dev for payments. This means that all existing Payment accounts will stop working.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 3

5 years ago
Just FYI:

I tried setting up a new Payment account on dev but this is different from stage now, and I got the same error:
Screencast: http://screencast.com/t/mpy9izqISf

Note: The same issue happened on stage but after setting up a new account this has been resolved.

Comment 4

5 years ago
Reopening this because comment 3 https://bugzilla.mozilla.org/show_bug.cgi?id=969284#c3
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Component: Developer Pages → Payments/Refunds

Updated

5 years ago
Priority: -- → P3
(Assignee)

Updated

5 years ago
Assignee: nobody → david
(Assignee)

Comment 5

5 years ago
Changing back to wontfix because there is a high probability that it came from inconsistent data due to the zippy/bango switch last week (I couldn't reproduce locally). Please reopen if you can reproduce with the next push.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX

Comment 6

5 years ago
This is still happening on DEV and now this is also see on STAGE when you're trying to set up a new account:

===
Oops! We had an error.
We'll get to fixing that soon.
You can try refreshing the page, or try again later.
===

Look at the screenshot!
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 7

5 years ago
Created attachment 8386763 [details]
Screenshot from 2014-03-06 15:11:27.png

Comment 8

5 years ago
Trying to edit a Bango account won't work on -dev. Especially if that account was copied from prod down to -dev in the recent refresh.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.