[Gaia] Need to add setting menus for 'dun' and 'ims' apn types

RESOLVED FIXED in 1.4 S2 (28feb)

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: kenkai, Assigned: jaoo)

Tracking

unspecified
1.4 S2 (28feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [FT:RIL])

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

4 years ago
Some carriers require the apn with type 'dun' for tethering and type 'ims' for IMS in LTE network. We need to add setting menus for these apn types
See Also: → bug 968092
(Reporter)

Comment 1

4 years ago
Ivan, we need help from Gaia system team for this setting menu.
Flags: needinfo?(itsay)
(Reporter)

Comment 2

4 years ago
It is a 1.4+ bug.
blocking-b2g: --- → 1.4+
(Assignee)

Comment 3

4 years ago
Go for it if you don't mind.
(Assignee)

Updated

4 years ago
Assignee: nobody → josea.olivera
(Assignee)

Comment 4

4 years ago
Created attachment 8372242 [details]
FFOS_Settings_APN_V1.2_20131007_V1.0.pdf

I'm wondering if the right thing to do here is just adding new panels for both DUN and IMS APNs. IMHO the user doesn't know about these APNs or even about the APN thing in general. On the other hand this bug would be a nice place to work on some changes for the panels for selecting APNs. This attachment is a proposal on how to change the UI.

Having said that. I'll request some feedback from the UX team about two question: i) In case we keep the current UI and UX does it make sense to add these two new panels?, does the user know about this type of APNs and their use?, ii) In case we change the UI, Is the proposal still valid? I mean, If we decide to go for it, who of you guys will be the person in charge of helping us?

Thanks!
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 5

4 years ago
Comment on attachment 8372242 [details]
FFOS_Settings_APN_V1.2_20131007_V1.0.pdf

Flagging the proposed APN work for ui-review?. Carrie, if this is 100% OK with you, please mark it ui-review+ with any comments you may have. If it needs changes/corrections, please mark it ui-review- with comments. Thank you!
Attachment #8372242 - Flags: ui-review?(cawang)
Flags: needinfo?(firefoxos-ux-bugzilla)
(Reporter)

Comment 6

4 years ago
Thanks, Jose.
Flags: needinfo?(itsay)
Comment on attachment 8372242 [details]
FFOS_Settings_APN_V1.2_20131007_V1.0.pdf

p.5 It would be better to put "APN Settings" to the next level, and add an entry "APN Settings" under "Advanced Settings"

And following the Building Blocks definition:
p.7 In Header, the controls should be X (quit without saving) instead of Back, and add an OK at right (save and quit)
p.7 Authentication type should use a Selector
p.7 APN Protocol should use a Selector
Attachment #8372242 - Flags: ui-review?(cawang) → ui-review-
(Assignee)

Comment 8

4 years ago
(In reply to Omega Feng [:Omega] from comment #7)
> Comment on attachment 8372242 [details]
> FFOS_Settings_APN_V1.2_20131007_V1.0.pdf

Could someone of you guys to attach the new version of the UX proposal? Thanks.
Flags: needinfo?(ofeng)
(Assignee)

Comment 9

4 years ago
IHMO the proposal should be reviewed a bit. As explained in the proposal the user must tap on the APN in the list to select it. This is a problem because the user must be able to see the APN properties and the APN form should be also opened by clicking the APN in the list as well.
This seems like a feature change. What feature in the roadmap is asking for this bug?
(Reporter)

Comment 11

4 years ago
Partners request to have this feature in Madai project.
remove 1.4 flag as this is a feature work. let's use metabug (b2g-LTE-1.4) to keep tracking.
blocking-b2g: 1.4+ → backlog
Whiteboard: [FT:RIL]
Target Milestone: --- → 1.4 S3 (14mar)
Created attachment 8376972 [details]
[1.4 Settings] APN Settings v1.0.pdf

Here is the UX proposal. Please see if you have any feedback.
Flags: needinfo?(ofeng)
(In reply to Omega Feng [:Omega] from comment #13)

> Here is the UX proposal. Please see if you have any feedback.

Thanks for the new proposal. Here are my comments:

The motivation for the change in the UI and the UX came from the need of group the APN of different types. Let me explain myself. An APN is basically an object with many properties. One of them ('types') is used to determinate which 'connection type (data call)/service' the APN is for. For example, 'default' type is for internet surfing and other stuff, 'mms' is for data calls for sending and receiving MMS messages and so on. The most important thing is that an APN might be used for several type of services.

Current UI and UX has different panels for each APN type and we wanted to avoid having them. So the idea was just having a list of APNs and adding to the APN details panel a field for types of services the APN is for.

The proposal here still has different panels/lists for each APN type. I would drop the buttons for MMS (Message Settings) and SUPL (A-GPS Settings) APNs and keep the one for 'Data Settings'. I would also change 'Data Settings' for just 'APN' but 'Data Settings' would also works for me.
(Assignee)

Updated

4 years ago
Flags: needinfo?(ofeng)
Blocks: 952026
No longer blocks: 960206
Created attachment 8378767 [details]
[1.4 Settings] APN Settings v1.1.pdf

Modified by suggestion in Comment #14
Please see if is OK this time.
Attachment #8376972 - Attachment is obsolete: true
Flags: needinfo?(ofeng)
set target milestone to Feb28 to align UC delivery date.
Target Milestone: 1.4 S3 (14mar) → 1.4 S2 (28feb)
Please let me know if the date doesn't work.
Flags: needinfo?(josea.olivera)
(In reply to Wesley Huang [:wesley_huang] from comment #17)
> Please let me know if the date doesn't work.

I'll try to do it. I'll let you know early next week.
Flags: needinfo?(josea.olivera)
(Assignee)

Updated

4 years ago
Attachment #8372242 - Attachment is obsolete: true
(In reply to Omega Feng [:Omega] from comment #15)
> Created attachment 8378767 [details]
> [1.4 Settings] APN Settings v1.1.pdf
> 
> Modified by suggestion in Comment #14
> Please see if is OK this time.

LGTM, thanks!

Comment 21

4 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #18)
> (In reply to Wesley Huang [:wesley_huang] from comment #17)
> > Please let me know if the date doesn't work.
> 
> I'll try to do it. I'll let you know early next week.

Update?
Flags: needinfo?(josea.olivera)
(In reply to Kevin Hu [:khu] from comment #21)
> (In reply to José Antonio Olivera Ortega [:jaoo] from comment #18)
> > (In reply to Wesley Huang [:wesley_huang] from comment #17)
> > > Please let me know if the date doesn't work.
> > 
> > I'll try to do it. I'll let you know early next week.
> 
> Update?

Working on it.
Flags: needinfo?(josea.olivera)

Comment 23

4 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #22)
> Working on it.

Thank you, Jose! 
May I know if this could be landed before 2/28?
Flags: needinfo?(josea.olivera)
(In reply to Kevin Hu [:khu] from comment #23)
> May I know if this could be landed before 2/28?

I expect to have a patch ready for review late tomorrow and then the patch needs to be reviewed. I'll do my best anyway.
Flags: needinfo?(josea.olivera)
(Assignee)

Updated

4 years ago
Blocks: 975259
I'll take care of bug 975259 here since this bug is redefining the whole APN UI. See https://bugzilla.mozilla.org/show_bug.cgi?id=975259#c5 please.
Comment on attachment 8383182 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/gaia/pull/16720

Fabien, this PR add a set of patches that add a couple of new panels for DUN (tethering) and IMS APNs. It also adds a couple of new fields in all the APN panels for a couple of new APN properties (protocol and roaming protocol). When I started working on this bug I thought this was a good chance to re-design the whole APN UI but IMHO that change is a very big change as we should avoid regression and finish the job before the 2/28 deadline expires. I split up the patch in different parts I hope this makes the review easier. So could you take a look at it please? Thanks!
Attachment #8383182 - Flags: review?(kaze)
Comment on attachment 8383182 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/gaia/pull/16720

Very good work, perfectly integrated in the Settings app.
Attachment #8383182 - Flags: review?(kaze) → review+
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #27)
> When I started working on this bug I thought this was a good chance to
> re-design the whole APN UI but IMHO that change is a very big change as we
> should avoid regression and finish the job before the 2/28 deadline expires.

Yes, the APN UI is getting a bit heavy these days, but that’s much better to avoid risk until we branch 1.4. This kind of polishing will be welcome a bit later (= in three weeks).
Thanks for the review Fabien. Everything seems to work fine, nothing is broken and travis went green. Landed on Gaia master branch at https://github.com/mozilla-b2g/gaia/commit/661a1e1a1f2e2a8af439a9330443a63668bf0589
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Is there any followup bug to track the implementation of the pending features described in the attachment 8378767 [details] ?
Flags: needinfo?(ofeng)

Comment 32

4 years ago
Flagging Ken, instead of Omega, to shed light on the implementation plan and/or schedule for this. Thanks Ken!
Flags: needinfo?(ofeng) → needinfo?(kchang)
(Reporter)

Comment 33

4 years ago
(In reply to Stephany Wilkes from comment #32)
> Flagging Ken, instead of Omega, to shed light on the implementation plan
> and/or schedule for this. Thanks Ken!

Currently, this bug was fixed. I think what Omega provided is an improvement for setting app because this design changes overall layout of current setting app. Ni?PM of setting app to know if they plan to do this improvement.
Flags: needinfo?(kchang) → needinfo?(bhuang)
I'd prefer to revamp the settings layout all at once, so we can track this as part of that, most likely post 2.0.  Working with UX on this one.
Flags: needinfo?(bhuang)

Comment 35

4 years ago
Created attachment 8440607 [details]
[2.0 Settings] APN Settings v1.2.pdf

Updated APN wireframe.
Attachment #8378767 - Attachment is obsolete: true
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.