Closed Bug 969345 Opened 6 years ago Closed 6 years ago

Crash in android.database.sqlite.SQLiteConstraintException: error code 19: constraint failed

Categories

(Firefox for Android :: General, defect, critical)

28 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 961526
Tracking Status
firefox28 --- affected

People

(Reporter: email, Unassigned)

Details

(Keywords: crash, Whiteboard: [native-crash])

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

1. Click on the addressbar
2. The tab "Most viewed pages" shows up, there are 9 entries visible as images
3. Do a rightclick on the first entry and select edit
4. No need to chanbge anything, just press Enter
5. Crash


Actual results:

Crash


Expected results:

No Crash ;) Updated entry
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Please visit about:crashes and report back on the crash ID associated with the crash so we can see if this is already on file.
Flags: needinfo?(email)
(In reply to Sven Strickroth from comment #2)
> https://crash-stats.mozilla.com/report/index/15148f09-9cbd-4109-9266-
> d830a2140207

New

> https://crash-stats.mozilla.com/report/index/42cc200d-ef7f-47f8-9fcc-
> c4f3c2130829

bug 833741 


> https://crash-stats.mozilla.com/report/index/2b1d8fb0-f9d4-41bf-9acd-
> 1b9a92140131

Same as the first.

Thanks.

android.database.sqlite.SQLiteConstraintException: error code 19: constraint failed
	at android.database.sqlite.SQLiteStatement.native_executeInsert(Native Method)
	at android.database.sqlite.SQLiteStatement.executeInsert(SQLiteStatement.java:113)
	at android.database.sqlite.SQLiteDatabase.insertWithOnConflict(SQLiteDatabase.java:1718)
	at android.database.sqlite.SQLiteDatabase.insertOrThrow(SQLiteDatabase.java:1617)
	at org.mozilla.gecko.db.BrowserProvider.insertBookmark(BrowserProvider.java:2845)
	at org.mozilla.gecko.db.BrowserProvider.updateOrInsertBookmark(BrowserProvider.java:2855)
	at org.mozilla.gecko.db.BrowserProvider.updateInTransaction(BrowserProvider.java:2471)
	at org.mozilla.gecko.db.BrowserProvider.update(BrowserProvider.java:2415)
	at android.content.ContentProvider$Transport.update(ContentProvider.java:219)
	at android.content.ContentResolver.update(ContentResolver.java:856)
	at org.mozilla.gecko.db.LocalBrowserDB.pinSite(LocalBrowserDB.java:1168)
	at org.mozilla.gecko.db.BrowserDB.pinSite(BrowserDB.java:285)
	at org.mozilla.gecko.home.TopSitesPage$EditPinnedSiteListener$1.run(TopSitesPage.java:422)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:32)
Status: UNCONFIRMED → NEW
Crash Signature: [@ android.database.sqlite.SQLiteConstraintException: error code 19: constraint failed at android.database.sqlite.SQLiteStatement.native_executeInsert(Native Method)]
Ever confirmed: true
Keywords: crash
Summary: Crash after editing "most visited pages" image entries → Crash in android.database.sqlite.SQLiteConstraintException: error code 19: constraint failed
Whiteboard: [native-crash]
Severity: normal → critical
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 961526
You need to log in before you can comment on or make changes to this bug.