Closed Bug 969356 Opened 6 years ago Closed 6 years ago

When mouse clicking on a top site tile, the watermark shifts

Categories

(Firefox for Metro Graveyard :: Firefox Start, defect, P1)

x86_64
Windows 8.1
defect

Tracking

(firefox28 verified, firefox29 verified, firefox30 verified, b2g-v1.3 fixed)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox28 --- verified
firefox29 --- verified
firefox30 --- verified
b2g-v1.3 --- fixed

People

(Reporter: jimm, Assigned: rsilveira)

References

Details

(Keywords: regression, Whiteboard: p=1 s=it-30c-29a-28b.2 r=ff30 [qa+])

Attachments

(1 file, 1 obsolete file)

STR:

1) click on a top site tile

result: the watermark background image will shift down briefly about 30px before about:start unloads.

this showed up on mc tip today.
No need to block v1, this is an mc only bug at this point.
No longer blocks: metrov1backlog
Hmm, its on aurora tip as well. I'll check beta next.
Rats, it's on beta too. We'll need to triage this to decide if we want to get a fix in. Hopefully it's something simple in our front end.
Whiteboard: [triage] → [release28] p=0
Whiteboard: [release28] p=0 → [release28] p=3
Whiteboard: [release28] p=3 → [release28] p=3 r=ff28
Assignee: nobody → jmathies
This is happening because we set a bottom padding based on [startpage] attribute here http://mxr.mozilla.org/mozilla-central/source/browser/metro/theme/browser.css#248. 

When we click a tile we unset the attrubute making the padding disappear and shift the watermark. We can move the padding to start.css and have it always on, and remove this one here.
Would you like to take this rsilveira? I'm wrapped up in other work.
Assignee: jmathies → nobody
Doesn't block unless bug 971124 lands.
Depends on: 971124
(In reply to Jim Mathies [:jimm] from comment #5)
> Would you like to take this rsilveira? I'm wrapped up in other work.
Sure.
Assignee: nobody → rsilveira
Attached patch Patch v1 (obsolete) — Splinter Review
Attachment #8374968 - Flags: review?(jmathies)
Attachment #8374968 - Flags: review?(jmathies) → review+
Status: NEW → ASSIGNED
Priority: -- → P1
QA Contact: jbecerra
Whiteboard: [release28] p=3 r=ff28 → [release28] p=1 s=it-30c-29a-28b.1 r=ff28
Backed out because fix hides the scrollbars and clips bottom tiles in snapped/portrait mode.

https://hg.mozilla.org/integration/fx-team/rev/733bb9bfcc14
Whiteboard: [release28] p=1 s=it-30c-29a-28b.1 r=ff28 → [release28] p=1 r=ff28
Attachment #8374968 - Attachment is obsolete: true
QA Contact: jbecerra → kamiljoz
Whiteboard: [release28] p=1 r=ff28 → [release28] p=1 s=it-30c-29a-28b.2 r=ff28
Priority: P1 → P2
Whiteboard: [release28] p=1 s=it-30c-29a-28b.2 r=ff28 → p=1 s=it-30c-29a-28b.2 r=ff30
Blocks: metrobacklog
No longer blocks: metrov1backlog
Priority: P2 → P1
Attached patch Patch v2Splinter Review
Fixed by changing when we unset the [startpage] attribute to when location changes.
Attachment #8378628 - Flags: review?(jmathies)
Comment on attachment 8378628 [details] [diff] [review]
Patch v2

Review of attachment 8378628 [details] [diff] [review]:
-----------------------------------------------------------------

works great!
Attachment #8378628 - Flags: review?(jmathies) → review+
are you planning on uplifting the watermark patch with this up to beta?
Yes, I think we should. It's the most visible piece of branding we have on the start page once you get it populated.

https://hg.mozilla.org/integration/fx-team/rev/a9a604b10f0e
https://hg.mozilla.org/mozilla-central/rev/a9a604b10f0e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
For testing and verification.  Reopen if any defects found.
Flags: needinfo?(kamiljoz)
Went through the following verification process using the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-24-03-02-03-mozilla-central/

Reproduced the original issue using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-07-03-02-01-mozilla-central/

Used the following test cases to ensure that the original issue from comment #0 wasn't occurring:

- Selected website tiles from "Top Sites"
- Selected website tiles from "Bookmarks"
- Selected website tiles from "Recent History"
- Selected website tiles from "Your Results" under the navigation app bar
- Selected website tiles from all of the above categories while about:start was scrolled in different positions
- Loaded a website via the URL text field under the navigation app bar
- Selected all the available websites under the flyouts while under about:start (privacy policy, feedback, help)
- Used both mouse and touch for all of the above test cases
- Ensured that there's no visible artifacts or other unexpected animations when clicking on tiles under about:start
- Used several different variations of snapped view for all of the above test cases

Waiting for this issue to be uplifted into Aurora/BETA to complete verification.
Flags: needinfo?(kamiljoz)
Whiteboard: p=1 s=it-30c-29a-28b.2 r=ff30 → p=1 s=it-30c-29a-28b.2 r=ff30 [qa+]
Comment on attachment 8378628 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): It's been there at least since bug 902937
User impact if declined: Watermark will shift down when loading a new site.
Testing completed (on m-c, etc.): On m-c since 02/21. Also QA tested, see comment #16
Risk to taking this patch (and alternatives if risky): Very low, affects metro only. Note that it only makes sense to uplift this one if bug 971124 is uplifted too.
String or IDL/UUID changes made by this patch: none.
Attachment #8378628 - Flags: approval-mozilla-beta?
Attachment #8378628 - Flags: approval-mozilla-aurora?
Attachment #8378628 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8378628 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Went through the following verification process with the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-26-00-40-01-mozilla-aurora/

- Went through the original test case from comment #0
- Went through all the test cases from comment #16
- Went through the above test cases using both the X1 Carbon and the Surface Pro 2

Didn't make it into Firefox 28.0b6, waiting for the next build to complete verification.
Went through the following verification process using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b7/win32/en-US/

- Went through the original test case from comment #0
- Went through all of the test cases from comment #16
- Went through the above test cases using both the X1 Carbon and the Surface Pro 2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.