Closed Bug 969393 Opened 6 years ago Closed 6 years ago

[v1.2] Import contacts from SD card is not working unless you enable SD card as "Default media location"

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S1 (9may)
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: nulti.korisnik, Assigned: mbudzynski)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

This was tested on b2g v1.2 (gaia-539a25e) on GP keon.

How to produce it:
- Do not change  "Settings > Storage > Default media location" and make sure that SD card is not the default for that option;
- Go to contacts;
- Try to import contacts from SD card.



Actual results:

I was unable to import contacts.


Expected results:

Import contacts whatever is the default location since it should be read from SD card directly no matter what is the "Default media location".

Possible duplicate: https://bugzilla.mozilla.org/show_bug.cgi?id=911631
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
This is not present in v1.3 (gaia 0ab8a9c). I just tested it.
Again tested on 1.3 and the bug is not present. I will close this bug as fixed for v1.3.
This bug is present in Firefox OS 1.3 on Keon device on latest update from 2014-04-04;

device: GP Keon
system version: 1.3 prerelease
git: 26fcc03f
build id: 20140406004832
blocking-b2g: --- → 2.0?
QAWANTED to confirm on Buri
Keywords: qawanted
(In reply to Joe Cheng [:jcheng] from comment #4)
> QAWANTED to confirm on Buri

Issue was NOT reproducible on Buri with 2.0 master build. On Buri I was not able to change 'Default media location' to anything other than SD card though, probably because it does not have internal storage.

Another similar bug: https://bugzilla.mozilla.org/show_bug.cgi?id=999588

Tested on:
Device: Buri MOZ
BuildID: 20140424040201
Gaia: d25852a189c9707b144eb5f82d08384eb066c0fd
Gecko: c8055a00235d
Version: 31.0a1
Firmware Version: v1.2-device.cfg
Keywords: qawanted
I think Leo or Inari may match this requirement.
Flags: needinfo?(pcheng)
(In reply to Alexandre LISSY :gerard-majax from comment #6)
> I think Leo or Inari may match this requirement.

Issue is reproducible on Leo with 1.3.
With "Default media location" set to internal, importing contacts from SD card is not possible.

Device: Leo 1.3 MOZ
BuildID: 20140317004001
Gaia: 0ab8a9cbcef5f23cec904a3d7f7675e44de29951
Gecko: f824e9d91a2d
Version: 28.0
Firmware Version: v10d
Flags: needinfo?(pcheng)
Assignee: nobody → mbudzynski
I will take a look on this later this sprint.
Comment on attachment 8417302 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18938

According to the spec we can have more than one SDCard volume (I'm not sure if 'volume' is a good word for this but I hope it's clear what I mean), so to find the good one we need to iterate through the list of storages [using getDeviceStorages('sdcard') instead of getDeviceStorage('sdcard')]
Comment on attachment 8417302 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18938

Michal asked me to take this on IRC as others are out currently.
Attachment #8417302 - Flags: review?(fernando.campo) → review?(bkelly)
Thanks Ben!
I'm sorry but things kind of blew up on my today.  I will review first thing in the morning.
Comment on attachment 8417302 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18938

A couple very minor nits on github.  r=me even if you decide not to take my two suggestions.

I verified that I can still import on my buri with this code.  I was not able to change my default media storage location, though, so could not really test the particular case described in the bug.
Attachment #8417302 - Flags: review?(bkelly) → review+
Thanks Ben, landed: https://github.com/mozilla-b2g/gaia/commit/dac94f9758001a7fb83eaf9c19d98c16d27947f1
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Removing the 2.0? as it's already landed in master
blocking-b2g: 2.0? → ---
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.