Error: onPacket threw an exception: Error: Server did not specify an actor

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
5 years ago
8 months ago

People

(Reporter: alice0775, Unassigned)

Tracking

30 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Timestamp: 2014/02/08 0:00:39
Error: onPacket threw an exception: Error: Server did not specify an actor, dropping packet: {"type":"pickerNodeHovered","node":{"node":{"actor":"conn2.domnode58","baseURI":"about:newtab","parent":"conn2.domnode59","nodeType":1,"namespaceURI":"http://www.w3.org/1999/xhtml","nodeName":"div","numChildren":0,"attrs":[{"name":"class","value":"newtab-side-margin"}]},"newParents":[{"actor":"conn2.domnode59","baseURI":"about:newtab","parent":"conn2.domnode60","nodeType":1,"namespaceURI":"http://www.w3.org/1999/xhtml","nodeName":"div","numChildren":7,"attrs":[{"name":"id","value":"newtab-horizontal-margin"}]},{"actor":"conn2.domnode60","baseURI":"about:newtab","parent":"conn2.domnode61","nodeType":1,"namespaceURI":"http://www.w3.org/1999/xhtml","nodeName":"div","numChildren":7,"attrs":[{"name":"id","value":"newtab-vertical-margin"}]},{"actor":"conn2.domnode61","baseURI":"about:newtab","parent":"conn2.domnode62","nodeType":1,"namespaceURI":"http://www.w3.org/1999/xhtml","nodeName":"div","numChildren":5,"attrs":[{"name":"id","value":"newtab-scrollbox"}]},{"actor":"conn2.domnode62","baseURI":"about:newtab","parent":"conn2.domnode63","nodeType":1,"namespaceURI":"http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul","nodeName":"xul:window","numChildren":2,"attrs":[{"name":"id","value":"newtab-window"},{"name":"xmlns","value":"http://www.w3.org/1999/xhtml"},{"name":"xmlns:xul","value":"http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"},{"name":"title","value":"New Tab"},{"name":"allow-background-captures","value":"true"}],"isDocumentElement":true},{"actor":"conn2.domnode63","baseURI":"about:newtab","nodeType":9,"namespaceURI":null,"nodeName":"#document","numChildren":4}]},"from":null}
Stack: DebuggerClient.prototype.onPacket/<@resource://gre/modules/devtools/dbg-client.jsm:655
resolve@resource://gre/modules/commonjs/sdk/core/promise.js:118
then@resource://gre/modules/commonjs/sdk/core/promise.js:43
then@resource://gre/modules/commonjs/sdk/core/promise.js:153
DebuggerClient.prototype.onPacket@resource://gre/modules/devtools/dbg-client.jsm:705
LDT_send/<@resource://gre/modules/devtools/dbg-client.jsm -> resource://gre/modules/devtools/server/transport.js:258
makeInfallible/<@resource://gre/modules/devtools/DevToolsUtils.jsm -> resource://gre/modules/devtools/DevToolsUtils.js:80
Line: 655, column: 0
Source File: resource://gre/modules/devtools/DevToolsUtils.jsm -> resource://gre/modules/devtools/DevToolsUtils.js
Line: 56

Reproducible: sometimes

Steps To Reproduce
1. Open about:newtab
2. Open Inspector(Ctrl+Shift+C) and close
Filter on CLIMBING SHOES
I tried several times to reproduce the issue but I wasn't able to. Since the bug's age, it could be possible that something changed in the meantime.

Alice, feel free to reopen it if you can still reproduce it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.