Closed Bug 969418 Opened 6 years ago Closed 6 years ago

Android - Sync options are greyed out on some devices and sync does not work

Categories

(Firefox for Android :: Android Sync, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 967580

People

(Reporter: catalin.suciu, Unassigned)

Details

Attachments

(1 file)

Attached file synclog.txt
Nightly 30.0a1 (2014-02-07)

Steps:  
1. Have the latest Nightly installed
2. Go to Settings -> Accounts & Sync and add a new Fx Account  
3. Create a Firefox account or sign into an old one
4. After signing in, go to Settings -> Accounts, tap on your Fx sync account,then tap on 'Configure Sync'

Expected:
The sync options can be checked/unchecked and sync should work

Actual:
The sync options are greyed out and sync doesn't work

The issue is reproducible on:
Samsung Galaxy Note (4.1.2)
Samsung Galaxy Tab (4.0)
Samsung Galaxy Tab 2 (4.2.2)
Samsung Galaxy Nexus (4.3)
Samsung Galaxy R (2.3.4)

Doesn't reproduce on:
Motorola Razr (4.0.4)
Alcatel OneTouch (4.1)
LG Nexus (4.4.2)
Component: Firefox Sync: UI → Android Sync
Product: Mozilla Services → Android Background Services
E/FxAccounts(14252): invalid Hawk signature → bug 967580

Can you double check that the clocks and date on the devices are set fairly accurately?
Flags: needinfo?(catalin.suciu)
This is exactly the same as Bug 967580 -- you can't change your Sync settings until you've successfully talked to the server to find out what they currently are, and your clock is so wrong that you're getting a 401 when fetching info/collections.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: clockskew
Can't reproduce after setting the correct time on device
Flags: needinfo?(catalin.suciu)
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.