Refresh and store list of installed/purchased/developed apps by the user

VERIFIED FIXED in 2014-03-04

Status

P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: mat, Assigned: mat)

Tracking

({perf})

2014-03-04
Points:
---

Details

(Assignee)

Description

5 years ago
Continuing the work on making the API faster and more cacheable, we need fireplace to be able to call search endpoints without '_user' parameter.

I already made consumer-info API able to return the list of app ids the user has installed/purchased/developed, so the idea is to:
- Have that list be returned on login as well (separate API bug to create)
- Have fireplace call consumer-info API in the background at some interval to be determined (maybe when the app is re-focused ? the most important part is that it needs to be done in a non-blocking way)
- Have fireplace use that info to patch the models it has in its cache
- Have fireplace stop sending '_user' parameter when calling search API endpoints.
(Assignee)

Updated

5 years ago
Whiteboard: [perf]
Priority: -- → P2
(Assignee)

Updated

5 years ago
Depends on: 973735
(Assignee)

Updated

5 years ago
Assignee: nobody → mpillard
(Assignee)

Comment 2

5 years ago
Fixed in https://github.com/mozilla/fireplace/commit/fe2744fe722565d2477eacea44b4f58fdfdd482a

STR:
- Go to consumer pages, log in as an user who has no special permissions
- Go visit an app, make sure the "edit listing" button is not shown.

- Log in with an user that developed an app
- Go to this app, make sure the "edit listing button" is shown

- Log in with an user with reviewer permissions
- Go to any app, make sure the "edit listing button" is shown

If you can test purchased apps (wait for this to land on stage ?):
- Go to consumer pages, log in as an user who has no special permissions
- Purchase an app, install it, reload the page. There should be a button to launch the app
- Open another browser, log in with the same account, visit the app. There should be a button to install the app (it should recognise you have purchased it already)
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-03-04

Comment 3

5 years ago
Verified scenarios:
Logged as an user with no special permissions : No "edit listing button" available -http://screencast.com/t/U1GARInlvS

Logged as an user with no special permissions(but developer of an app) : http://screencast.com/t/59vzi9rBx5x

Logged as an user with special permissions : "Edit listing" available - http://screencast.com/t/VbvCnx5fmP5P

I will verify the rest of scenarios after stage push.

Comment 4

5 years ago
STR:
1. Log in to desktop marketplace.
2. Install an app like "OfficeMaps". Notice that the button status changes to "Launch"
3. Using the same account used in #1, log in to Marketplace-dev on your tablet.
4. Search for the same app (OfficeMaps)
5. Note that button status is "Install" instead of "Free"
6. Log out
7. Search for the same app (OfficeMaps) again

expected behavior:
Button status is "Free" after logging out

actual behavior:
Button status is "Install" after logging out

ashes: 9d0f0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
I continued the investigations on this bug with following findings :

1.On Stage, I verified the scenario from comment 2 for paid apps and everything worked as expected(Purchased apps are provided with Install button for the same user if another browser or device is used)

2.Verified Krupa's scenario and apps install buttons are seen as Free after logging out

3.I observed a similar behavior with Krupa's one , but for paid apps:
1. Log in to FF-OS MP Stage marketplace.
2. Purchase and Install a paid app
3. Using the same account used in #1, log in to Marketplace stage on your Android device.
4. Search for the same app 
5. Note that button status is "Install" instead of "Purchase"
6. Log out
7. Search for the same app again

expected behavior:
Button status is "Purchase" after logging out

actual behavior:
Button status is "Install" after logging out

I am pretty sure that this scenario is fixed too by the last commit, but I am not able to test it on -dev, because I am not able to purchase here, so I will wait for a push before marking the bug as verified.

Comment 7

5 years ago
A push to stage was performed and I verified the last scenario and now everything is working as expected.
Marking bug as verified...
Status: RESOLVED → VERIFIED
Keywords: perf
Whiteboard: [perf]
(Assignee)

Updated

4 years ago
Duplicate of this bug: 880772
You need to log in before you can comment on or make changes to this bug.