Closed Bug 969455 Opened 6 years ago Closed 6 years ago

APZC enabled: Scroll position within the input field when entering a message is being snapped back to last paint location

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla30
blocking-b2g 1.4+
Tracking Status
firefox28 --- wontfix
firefox29 --- wontfix
firefox30 --- fixed
b2g-v1.3 --- unaffected
b2g-v1.4 --- fixed

People

(Reporter: drs, Assigned: kats)

References

Details

(Keywords: regression, smoketest)

Attachments

(4 files)

See attached video.
Attached video Video
If this is a very recent regression then it might be bug 963278.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> If this is a very recent regression then it might be bug 963278.

vingtetun claims it's a regression from a day ago, so yes, that's quite likely.
blocking-b2g: --- → 1.3?
blocking-b2g: 1.3? → ---
Botond said that backing out bug 963278 fixed it for him. Note that if we do back out 963278 on master, we should also back out bug 965351 which depends on it. (Otherwise you'll get test failures)
Botond said the STR in this bug still caused a problem for him with the backout, so I'm not sure what's going on. Maybe multiple regressions? I will try to verify on my device.
No longer blocks: 963278
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> Botond said the STR in this bug still caused a problem for him with the
> backout

Actually that was for bug 969554. (The bug numbers are quite similar, I mixed them up a few times myself). The remaining problem I saw there was scrolling getting "stuck" sometimes, not jumping back to the origin, so it could very well be a different problem.
Assignee: nobody → bugmail.mozilla
Attached patch FixSplinter Review
This has to be the stupidest mistake I've made yet.
Attachment #8373354 - Flags: review?(bugzilla+drs)
Attachment #8373354 - Flags: review?(bugzilla+drs) → review+
Comment on attachment 8373356 [details] [diff] [review]
Logging update

Review of attachment 8373356 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/layers/ipc/AsyncPanZoomController.cpp
@@ +61,5 @@
>  
>  // #define APZC_ENABLE_RENDERTRACE
>  
> +// #define APZC_LOG(...)
> +#define APZC_LOG(...) printf_stderr("APZC: " __VA_ARGS__)

You left your debugging setting in here.
Attachment #8373356 - Flags: review?(bugzilla+drs) → review+
No longer blocks: 969810
Duplicate of this bug: 969810
Nice catch(In reply to Doug Sherk (:drs) from comment #10)
> 
> You left your debugging setting in here.

Good catch, thanks. Fixed that and landed on inbound:

remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/6fda903b4571
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/6f724675d1bc
No longer blocks: 970229
Duplicate of this bug: 970229
Duplicate of this bug: 969452
Keywords: smoketest
blocking-b2g: --- → 1.4+
No longer blocks: 970070
Attached file logcat
title edit: this also happens on email app.  disabling APZC will scroll as expected.

see my screencast. http://youtu.be/lQewm9aGg6w


Logcat snippet.  full logcat attached.
--------------------
02-10 14:50:05.381: I/Gecko(1603): [32mWLOG: runOp_end(do: {"type":"downloadBodies","longtermId":"0/5","lifecycle":"do","localStatus":"done","serverStatus":"doing","tryCount":0,"humanOp":"downloadBodies","messages":[{"s)
02-10 14:50:05.381: I/Gecko(1603): [0m
02-10 14:50:05.391: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.421: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.441: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.461: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.471: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.501: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.511: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.531: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.551: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.571: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.581: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.601: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.621: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.631: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.661: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.671: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory
02-10 14:50:05.691: E/msm7627a.hwcomposer(136): hwc_set: Unable to render by hwc due to non-pmem memory

Repro:
1) install trunk nightly on Buri Device.
Gaia      c273bd6525f7f295539592ce74d5e6b225d53be1
Gecko     https://hg.mozilla.org/mozilla-central/rev/ecf20a2484b6
BuildID   20140210040202
Version   30.0a1
ro.build.version.incremental=324

2) enable APZC
3) setup email with multiple threads so you can scroll
4) try to scroll, and verify it doesnt go up or down the list

Expected:
- scrolling works with APZC works
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Summary: SMS app's scroll position within the input field when entering a message is being snapped back to last paint location → APZC enabled: Scroll position within the input field when entering a message is being snapped back to last paint location
https://hg.mozilla.org/mozilla-central/rev/6fda903b4571
https://hg.mozilla.org/mozilla-central/rev/6f724675d1bc
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Duplicate of this bug: 969442
Verified fixed. 
Able to scroll and Sign In successfully to Persona/Gmail/Outlook (dup bug 969452)
No issues when scrolling video playlist (dup bug 969442)

Buri 1.4 master build
BuildID: 20140211040200
Gaia: 9fc36dde3a4a3c5ca200275b68ffb56b4173bec3
Gecko: d812f80a0f1d
Version: 30.0a1
Firmware Version: v1.2-devices.cfg
Status: RESOLVED → VERIFIED
The "fix" patch on this bug was uplifted to 1.3 in order to fix bug 980041. It is rolled up inside this changeset:

https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/46bb232303b8
You need to log in before you can comment on or make changes to this bug.