xpcshell reruns "tests that failed when run in parallel" when only a single test was executed

RESOLVED FIXED in mozilla35

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: gps, Assigned: mak)

Tracking

unspecified
mozilla35
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
If you run a single xpcshell test and it fails, the xpcshell test harness will do the re-run-tests-that-failed-in-parallel dance even though you only ran a single test. That's silly.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 1019582
(Assignee)

Comment 2

4 years ago
Created attachment 8499594 [details] [diff] [review]
patch v1

this is SO MUCH annoying...
Attachment #8499594 - Flags: review?(gps)
(Reporter)

Comment 3

4 years ago
Comment on attachment 8499594 [details] [diff] [review]
patch v1

Review of attachment 8499594 [details] [diff] [review]:
-----------------------------------------------------------------

This gets r+. But I really think the better place to patch this is inside the "should I re-run" logic in runxpcshelltests.py.
Attachment #8499594 - Flags: review?(gps) → review+
(Assignee)

Comment 4

4 years ago
I tried different code points to fix this, included runxpcshelltests.py, but down there there's too much convoluted logic to catch all of the points, every time I fixed something, some other piece was still wrong (even if just some output). Plus I thought that, since retry is an input argument, some other consumer (not mach) may want to actually force retry on a single test, who knows?
In the end, this was the shorter and safer patch I could made.
(Reporter)

Comment 5

4 years ago
After looking at runxpcshelltests.py, I agree with you: it is a hornets nest in there. This patch is simplest. Land it.
(Assignee)

Updated

4 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
(Assignee)

Comment 6

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/88664bb1a031
Target Milestone: --- → mozilla35
https://hg.mozilla.org/mozilla-central/rev/88664bb1a031
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.