Abs pos element with 'top:auto' displaced by first line of following normal-flow inline element.

RESOLVED DUPLICATE of bug 94468

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 94468
17 years ago
17 years ago

People

(Reporter: Val Sharp, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)
BuildID:    2001080110

If an abs pos element has (default) 'top:auto', then the top should be 
positioned as if the element had a position of 'static-position'.

However, an inline element following the abs pos element appears to interfere 
with the positioning of the abs pos element, such that it will be positioned 
after the first line of the following inline element.


Reproducible: Always
Steps to Reproduce: The attached testcase illustrates this.


Expected Results:  A following element should not affect the positioning of an 
abs pos element, and the abs pos element should overwrite the start of any 
subsequent element.
(Reporter)

Comment 1

17 years ago
Created attachment 47112 [details]
Testcase - abs pos element displaced by following inline element

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 94468 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.