Closed Bug 969656 Opened 6 years ago Closed 6 years ago

"Sign in again" menu panel UI should link directly to the sign-in page, rather than preferences

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: Gavin, Assigned: ttaubert)

References

Details

(Whiteboard: [qa!])

Attachments

(1 file)

The "reconnect to sync" error state in the menu panel should go directly to the sign in page, rather than opening Sync preferences, matching what happens if you click "Sign in" on the doorhanger.

In practice I think this means browser-fxaccounts' onMenuPanelCommand needs to handle three cases:
- sync not set up: this.openAccountsPage();
- sync signed in: this.openPreferences();
- sync set up but auth failed: this.openSignInAgainPage()

(It currently only handles the first two.)

this.loginFailed should probably be used to distinguish between the second two cases.
Whiteboard: p=0
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Whiteboard: p=0 → p=0, [qa+]
Attachment #8374053 - Flags: review?(gavin.sharp) → review+
https://hg.mozilla.org/mozilla-central/rev/a73a740fa69f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
No longer blocks: fxdesktopbacklog
Whiteboard: p=0, [qa+] → [qa+]
Whiteboard: [qa+] → [qa+] p=0
No longer blocks: fxdesktopbacklog
Whiteboard: [qa+] p=0 → [qa+]
QA Contact: twalker
Gavin, How do you get into the "reconnect to sync" error state in the menu panel?
Flags: needinfo?(gavin.sharp)
You can reach this state by signing into FxA on on browser and then changing the password for the same account on another profile. The original profile should then tell you to reconnect on next startup.
Flags: needinfo?(gavin.sharp)
Tim, thank you.

Verified with latest Nightly builds.  reconnect to sync account Sign-in button goes directly to sign-in page.
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
Should this be uplifted to Aurora?
Yup, just wanted to wait until it's verified.
Comment on attachment 8374053 [details] [diff] [review]
0001-Bug-969656-Sign-in-again-menu-panel-UI-should-link-d.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): ?
User impact if declined: Users would be sent to the prefs dialog instead of the sign-in page when clicking the error message that says "sign in again".
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): No risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8374053 - Flags: approval-mozilla-aurora?
Is it safe to assume all these Sync UI fixes from 2 week sprints should be uplifted?
Keywords: verifyme
Whiteboard: [qa!] → [qa+]
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #10)
> Is it safe to assume all these Sync UI fixes from 2 week sprints should be
> uplifted?

Yeah, most or all of the sync bugs we're currently working on are higher priority and we will want them in 29 as well. Thanks for keeping an eye on this!
Attachment #8374053 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 976598
Keywords: verifyme
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.