multiple address, one with no domain, is spread to two different lines in compose

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Todd, Unassigned)

Tracking

24 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8372665 [details]
CommaError.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

When some one wends you an eMail where the comment field part of their address contains a comma (",") and you press reply, the senders address gets split across two lines.

Steps to reproduce:

1) send yourself an eMail.  In the To: field, put a comma in the comment field.
For instance:    To: bozo, the clown <toddandmargo@zoho.com>

2) get your mail and press reply.  The senders address will split across two lines

I have some tech support people I have to write that love to put commas in their comment field:  "acme, inc.<support@acme.com>"   Especially if the use "inc." in their comment.

Many thanks,
-T

Comment 1

4 years ago
A comma is the delimiter between multiple email addresses. If you'd like to include a comma in the display name, you need to surround the name with quotation marks, like so:

  "bozo, the clown" <bozo@clowncollege.edu>

Otherwise, pretty much every mail client will assume you meant to send to two different addresses. If others are sending you mail like this, you should let them know that they're doing it wrong and they should fix it.

Note that if you set your identity's display name to have a comma in it, or have commas in the address book display name for a contact, Thunderbird should automatically handle the quoting for you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

4 years ago
Hi Jim,

The bug was the way I received mails from others, not how I was sending them.

This is from an offending message's source:

Date: Fri, 07 Feb 2014 18:10:01 +0000
From: "xxxxxx, Inc." <support@xxxxxx.com>
Reply-To: Cimcor, 
 "Inc." <support@cimcor.com>
To: toddandmargo@zoho.com

You will notice that the "From:" does have quotes in it.  The "Reply-To:" scrolled, placing the quotes in the wrong place, so maybe that is where the error occurred?

Many thanks,
-T
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

4 years ago
Yeah, if you're replying to that message, it's going to use the Reply-To header, which to a mail client, looks like it's asking you to reply to two separate addresses (although the first one isn't syntactically valid).

Comment 4

4 years ago
(In reply to Todd from comment #2)
> Reply-To: Cimcor, 
>  "Inc." <support@cimcor.com>

Per bug 724342 and applicable http://tools.ietf.org/html/rfc5322#section-3.4.1 standard, a valid mailbox address (with the exception of "postmaster") must always contain a '@' between local and domain parts. Consequently, this could be used to identify the incomplete first address and at least ignore it for filling the headers in a reply (same applies for "To:" and "Cc:" headers) to avoid that addressees are sent out which are entirely invalid. There may be a bug pending on this already, I couldn't find anything though.

Comment 5

4 years ago
As bad as the current behavior is (if you presume it is bad), isn't it better than completely ignoring the bad address and the user NOT knowing that one of the cc: to: or reply-to: address were excluded in their reply?

INVALID?
Component: Untriaged → Message Compose Window
Flags: needinfo?(squibblyflabbetydoo)

Comment 6

4 years ago
Yeah, I think we're being as correct as we can. It's not necessary correct to assume that the following should be folded into one address:

> Reply-To: Cimcor, 
>  "Inc." <support@cimcor.com>

It's entirely possible that the text before the comma was a totally separate email that got truncated somehow. By showing it in the addressing widget, users can actually see what happened and do something about it if necessary (and if they don't do anything, it should still send anyway).

Maybe when we switch to single-line addressing widgets, we'll need to be smarter, but not now.
Flags: needinfo?(squibblyflabbetydoo)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID
Summary: address with commas in then spread to two different lines → multiple address, one with no domain, is spread to two different lines in compose
You need to log in before you can comment on or make changes to this bug.