Closed Bug 969719 Opened 6 years ago Closed 6 years ago

Get rid of level="top" workaround for standalone panels introduced by bug 886317

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

NB: this does need to be tested. The try build is gone, we should follow the steps in that bug and check if we really still need this or not.
Try build: remote:   https://tbpl.mozilla.org/?tree=Try&rev=f0c98e86f1ad
Blocks: 886317
Status: NEW → ASSIGNED
(In reply to :Gijs Kruitbosch from comment #2)
> Try build: remote:   https://tbpl.mozilla.org/?tree=Try&rev=f0c98e86f1ad

This WFM with the steps from bug 886317 comment 0.
Comment on attachment 8372809 [details] [diff] [review]
get rid of level='top' workaround for Australis standalone panels,

Thanks!
Attachment #8372809 - Flags: review?(MattN+bmo) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/bb4595b33341
Whiteboard: [fixed-in-fx-team]
Comment on attachment 8372809 [details] [diff] [review]
get rid of level='top' workaround for Australis standalone panels,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 886317 / Australis
User impact if declined: small (e.g. the panels will go over the top of the taskbar, whereas they should really just stop before the taskbar, like they do when in the main menu panel), unless the UI tour can open these panels, in which case, level="top" is the wrong thing to do. The main reason to uplift this isn't user impact, it's consistency with the main panel and ensuring they behave similarly as much as possible
Testing completed (on m-c, etc.): locally, for the specific regression that was addressed adding this loc in bug 886317
Risk to taking this patch (and alternatives if risky): low/none
String or IDL/UUID changes made by this patch: none
Attachment #8372809 - Flags: approval-mozilla-aurora?
Attachment #8372809 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attached patch Patch for Aurora (obsolete) — Splinter Review
Comment on attachment 8372990 [details] [diff] [review]
Patch for Aurora

bzexport fail, sorry for the spam
Attachment #8372990 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/bb4595b33341
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Per bug 886317, Verified with latest builds of Nightly
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.