Closed Bug 969723 Opened 6 years ago Closed 6 years ago

Intermittent testOverscroll | Exception caught - junit.framework.AssertionFailedError: EditText is not found!

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 915449

People

(Reporter: KWierso, Assigned: gbrown)

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=34310535&tree=Mozilla-Inbound
slave: talos-linux64-ix-060



13:40:27     INFO -  Robocop process name: org.mozilla.fennec
13:40:27     INFO -  INFO | automation.py | Application pid: 0
13:40:27     INFO -  0 INFO SimpleTest START
13:40:27     INFO -  1 INFO TEST-START | testOverscroll
13:40:27     INFO -  2 INFO TEST-PASS | testOverscroll | Given message occurred for registered event: {"type":"Gecko:Ready"} - Gecko:Ready should equal Gecko:Ready
13:40:27     INFO -  EventExpecter: no longer listening for Gecko:Ready
13:40:27     INFO -  Exception caught during test!
13:40:27     INFO -  junit.framework.AssertionFailedError: EditText is not found!
13:40:27     INFO -  	at junit.framework.Assert.fail(Assert.java:50)
13:40:27     INFO -  	at junit.framework.Assert.assertTrue(Assert.java:20)
13:40:27     INFO -  	at com.jayway.android.robotium.solo.Waiter.waitForAndGetView(Waiter.java:510)
13:40:27     INFO -  	at com.jayway.android.robotium.solo.Getter.getView(Getter.java:50)
13:40:27     INFO -  	at com.jayway.android.robotium.solo.Solo.getEditText(Solo.java:1835)
13:40:27     INFO -  	at org.mozilla.gecko.tests.BaseTest$1.isSatisfied(BaseTest.java:195)
13:40:27     INFO -  	at com.jayway.android.robotium.solo.Waiter.waitForCondition(Waiter.java:370)
13:40:27     INFO -  	at com.jayway.android.robotium.solo.Solo.waitForCondition(Solo.java:426)
13:40:27     INFO -  	at org.mozilla.gecko.tests.BaseTest.waitForCondition(BaseTest.java:302)
13:40:27     INFO -  	at org.mozilla.gecko.tests.BaseTest.focusUrlBar(BaseTest.java:192)
13:40:27     INFO -  	at org.mozilla.gecko.tests.BaseTest.enterUrl(BaseTest.java:211)
13:40:27     INFO -  	at org.mozilla.gecko.tests.BaseTest.inputAndLoadUrl(BaseTest.java:242)
13:40:27     INFO -  	at org.mozilla.gecko.tests.PixelTest.loadAndGetPainted(PixelTest.java:10)
13:40:27     INFO -  	at org.mozilla.gecko.tests.PixelTest.loadAndVerifyBoxes(PixelTest.java:122)
13:40:27     INFO -  	at org.mozilla.gecko.tests.testOverscroll.testOverscroll(testOverscroll.java:25)
13:40:27     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
13:40:27     INFO -  	at java.lang.reflect.Method.invoke(Method.java:511)
13:40:27     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
13:40:27     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
13:40:27     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
13:40:27     INFO -  	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:150)
13:40:27     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:134)
13:40:27     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:115)
13:40:27     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:133)
13:40:27     INFO -  	at junit.framework.TestResult.run(TestResult.java:118)
13:40:27     INFO -  	at junit.framework.TestCase.run(TestCase.java:124)
13:40:27     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:190)
13:40:27     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:175)
13:40:27     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:555)
13:40:27     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1661)
13:40:27     INFO -  3 INFO TEST-UNEXPECTED-FAIL | testOverscroll | Exception caught - junit.framework.AssertionFailedError: EditText is not found!
13:40:27     INFO -  4 INFO TEST-END | testOverscroll | finished in 13271ms
13:40:27     INFO -  5 INFO TEST-START | Shutdown
13:40:27     INFO -  6 INFO Passed: 1
13:40:27  WARNING -  7 INFO Failed: 1
13:40:27  WARNING -  One or more unittests failed.
13:40:27     INFO -  8 INFO Todo: 0
13:40:27     INFO -  9 INFO SimpleTest FINISHED
13:40:27     INFO -  INFO | automation.py | Application ran for: 0:00:15.726034
13:40:27     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmp6AHArnpidlog
13:40:27     INFO -  /data/anr/traces.txt not found
13:40:27     INFO -  WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
13:40:27     INFO -  runtests.py | Running tests: end.
13:40:27     INFO -  Mochi-Remote INFO | 
13:40:27     INFO -  
13:40:27     INFO -  02-07 21:31:48.895 D/GeckoToolbar( 3578): onTabChanged: THUMBNAIL
13:40:27     INFO -  02-07 21:31:48.895 D/GeckoBrowserApp( 3578): BrowserApp.onTabChanged: 0: THUMBNAIL
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): Exception caught during test!
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): junit.framework.AssertionFailedError: EditText is not found!
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at junit.framework.Assert.fail(Assert.java:50)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at junit.framework.Assert.assertTrue(Assert.java:20)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at com.jayway.android.robotium.solo.Waiter.waitForAndGetView(Waiter.java:510)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at com.jayway.android.robotium.solo.Getter.getView(Getter.java:50)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at com.jayway.android.robotium.solo.Solo.getEditText(Solo.java:1835)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.BaseTest$1.isSatisfied(BaseTest.java:195)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at com.jayway.android.robotium.solo.Waiter.waitForCondition(Waiter.java:370)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at com.jayway.android.robotium.solo.Solo.waitForCondition(Solo.java:426)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.BaseTest.waitForCondition(BaseTest.java:302)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.BaseTest.focusUrlBar(BaseTest.java:192)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.BaseTest.enterUrl(BaseTest.java:211)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.BaseTest.inputAndLoadUrl(BaseTest.java:242)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.PixelTest.loadAndGetPainted(PixelTest.java:10)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.PixelTest.loadAndVerifyBoxes(PixelTest.java:122)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.testOverscroll.testOverscroll(testOverscroll.java:25)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at java.lang.reflect.Method.invokeNative(Native Method)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at java.lang.reflect.Method.invoke(Method.java:511)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:150)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at junit.framework.TestCase.runBare(TestCase.java:134)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at junit.framework.TestResult$1.protect(TestResult.java:115)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at junit.framework.TestResult.runProtected(TestResult.java:133)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at junit.framework.TestResult.run(TestResult.java:118)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at junit.framework.TestCase.run(TestCase.java:124)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:190)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:175)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:555)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1661)
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 3 INFO TEST-UNEXPECTED-FAIL | testOverscroll | Exception caught - junit.framework.AssertionFailedError: EditText is not found!
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 4 INFO TEST-END | testOverscroll | finished in 13271ms
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 5 INFO TEST-START | Shutdown
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 6 INFO Passed: 1
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 7 INFO Failed: 1
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 8 INFO Todo: 0
13:40:27     INFO -  02-07 21:31:59.745 I/Robocop ( 3578): 9 INFO SimpleTest FINISHED
13:40:27     INFO -  02-07 21:31:59.764 I/dalvikvm-heap( 3578): Grow heap (frag case) to 8.204MB for 3145740-byte allocation
13:40:27     INFO -  02-07 21:31:59.774 I/dalvikvm-heap( 3578): Grow heap (frag case) to 11.206MB for 3145740-byte allocation
13:40:27     INFO -  02-07 21:31:59.865 D/GeckoHealthRec( 3578): Recording session end: P
13:40:27     INFO -  02-07 21:31:59.875 V/GeckoHealthRec( 3578): Recorded session entry for env 1, current is 1
13:40:27     INFO -  02-07 21:31:59.875 D/GeckoSessInfo( 3578): Recording session done: 1391808706642
13:40:27     INFO -  02-07 21:31:59.885 I/GeckoHealth( 3578): fennec :: HealthReportBroadcastService :: Registering HealthReportPruneService.
13:40:27     INFO -  02-07 21:31:59.885 I/GeckoHealth( 3578): fennec :: BackgroundService :: Setting inexact repeating alarm for interval 86400000
13:40:27     INFO -  02-07 21:31:59.925 E/SurfaceFlinger(  802): ro.sf.lcd_density must be defined as a build property
13:40:27     INFO -  02-07 21:31:59.925 V/PhoneStatusBar( 1282): setLightsOn(true)
13:40:27     INFO -  02-07 21:31:59.985 W/GeckoGLController( 3578): GLController::serverSurfaceDestroyed() with mCompositorCreated=true
13:40:27     INFO -  02-07 21:31:59.995 W/GeckoGLController( 3578): done GLController::serverSurfaceDestroyed()
13:40:27     INFO -  02-07 21:32:00.494 W/ActivityManager( 1203): Duplicate finish request for ActivityRecord{b32810e0 u0 org.mozilla.fennec/.App}
13:40:27     INFO -  02-07 21:32:00.804 W/InputDispatcher( 1203): Permission denied: injecting event from pid 3578 uid 10046 to window Window{b3387940 u0 com.mozilla.SUTAgentAndroid/com.mozilla.SUTAgentAndroid.SUTAgentAndroid} owned by uid 10045
13:40:27     INFO -  02-07 21:32:00.804 W/InputManager( 1203): Input event injection from pid 3578 permission denied.
13:40:27     INFO -  02-07 21:32:00.804 W/ActivityManager( 1203): Duplicate finish request for ActivityRecord{b32810e0 u0 org.mozilla.fennec/.App}
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): failed: testOverscroll(org.mozilla.gecko.tests.testOverscroll)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): ----- begin exception -----
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): junit.framework.AssertionFailedError: 3 INFO TEST-UNEXPECTED-FAIL | testOverscroll | Exception caught - junit.framework.AssertionFailedError: EditText is not found!
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at junit.framework.Assert.fail(Assert.java:50)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at org.mozilla.gecko.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:110)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at org.mozilla.gecko.FennecMochitestAssert.ok(FennecMochitestAssert.java:139)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:157)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at junit.framework.TestCase.runBare(TestCase.java:134)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at junit.framework.TestResult$1.protect(TestResult.java:115)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at junit.framework.TestResult.runProtected(TestResult.java:133)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at junit.framework.TestResult.run(TestResult.java:118)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at junit.framework.TestCase.run(TestCase.java:124)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:190)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:175)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:555)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): 	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1661)
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): ----- end exception -----
13:40:27     INFO -  02-07 21:32:00.824 I/TestRunner( 3578): finished: testOverscroll(org.mozilla.gecko.tests.testOverscroll)
13:40:27     INFO -  02-07 21:32:00.824 D/AndroidRuntime( 3568): Shutting down VM
13:40:27     INFO -  02-07 21:32:00.834 I/ActivityManager( 1203): Force stopping package org.mozilla.fennec appid=10046 user=0
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915449
You need to log in before you can comment on or make changes to this bug.