All users were logged out of Bugzilla on October 13th, 2018

chip.de sends desktop site to Firefox OS

RESOLVED WONTFIX

Status

P5
normal
RESOLVED WONTFIX
5 years ago
3 months ago

People

(Reporter: sezen.guenes, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-de][clientsniff][needscontact], URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140205162153

Steps to reproduce:

I visited chip.de with Firefox OS.


Actual results:

I got a Desktop Website.


Expected results:

I expected a Mobile Website.
The browser detection in this javascript:

http://www.chip.de/js/mobileredirect.js?v=8

fails to detect Firefox OS devices as smartphones.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-de][clientsniff][contactready]
It appears that function is_mobile in the script at http://www.chip.de/js/mobileredirect.js?v=8 is from an outdated version of detectmobilebrowsers.com.

The suggested fix would be to update it with the current version which correctly recognizes Firefox mobile browsers (among others).
(Assignee)

Comment 3

4 years ago
contactemail
The main company seems to be 
http://www.chip-media.de/home.html

Tried to contact someone at Chip.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [country-de][clientsniff][contactready] → [country-de][clientsniff][sitewait]
(Assignee)

Comment 5

3 years ago
Firefox Android, and Chrome Android are still redirected to mobile.
The desktop site is slightly responsive so it gives the impression to work on Firefox OS, but there are still issues. 
The issue is till here. 

no answer from the previous contact switching to needscontact.
Whiteboard: [country-de][clientsniff][sitewait] → [country-de][clientsniff][needscontact]
Closing as we are not working on Firefox OS anymore.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.