Closed Bug 969963 Opened 6 years ago Closed 6 years ago

Grey out PanelUI-popup items when a subview is opened

Categories

(Firefox :: Theme, enhancement)

30 Branch
enhancement
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: ntim, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3-])

Attachments

(1 file, 1 obsolete file)

Mockup : http://people.mozilla.org/~shorlander/mockups-interactive/australis-interactive-mockups/windows8.html
The mockup shows that the PanelUI-mainview is grayed out when a subview is selected.
Whiteboard: [Australis:P3]
Whiteboard: [Australis:P3] → [Australis:P3-]
Component: General → Theme
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: shorlander → jaws
Status: NEW → ASSIGNED
Attached patch Patch (obsolete) — Splinter Review
Attachment #8394939 - Flags: review?(mconley)
Attached patch Patch v1.1Splinter Review
Now also greying out the searchbar if it is in the panel.
Attachment #8394939 - Attachment is obsolete: true
Attachment #8394939 - Flags: review?(mconley)
Attachment #8394982 - Flags: review?(mconley)
Severity: normal → enhancement
Comment on attachment 8394982 [details] [diff] [review]
Patch v1.1

Review of attachment 8394982 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! Just an indentation nit to fix.

::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
@@ +328,5 @@
>    margin: 4px auto;
>  }
>  
> +#PanelUI-multiView[viewtype="subview"] > .panel-viewcontainer > .panel-viewstack > .panel-mainview >  #PanelUI-mainView {
> +    background-color: hsla(210,4%,10%,.1);

Two-space indentation - same below, please.
Attachment #8394982 - Flags: review?(mconley) → review+
Fixed the indentation and also one other four-space indentation that crept through from bug 934075.

https://hg.mozilla.org/integration/fx-team/rev/c3f3754bdf29
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
It hasn't landed in mozilla central yet.
https://hg.mozilla.org/mozilla-central/rev/c3f3754bdf29
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
Comment on attachment 8394982 [details] [diff] [review]
Patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): theme changes for Australis
User impact if declined: higher visual noise from the main view of the new Panel menu when looking at a subview
Testing completed (on m-c, etc.): tested on m-c for a couple days now
Risk to taking this patch (and alternatives if risky): none expected
String or IDL/UUID changes made by this patch: none
Attachment #8394982 - Flags: approval-mozilla-aurora?
Attachment #8394982 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: checkin-needed
Comment on attachment 8394982 [details] [diff] [review]
Patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): theme changes for Australis
User impact if declined: higher visual noise from the main view of the new Panel menu when looking at a subview
Testing completed (on m-c, etc.): on m-c now for over a week
Risk to taking this patch (and alternatives if risky): none expected
String or IDL/UUID changes made by this patch: none
Attachment #8394982 - Flags: approval-mozilla-beta?
Attachment #8394982 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed on Windows 7 64bit, Mac OS X 10.9.2, Ubuntu 12.04 32bit and Windows 8.1 64bit using Firefox 29 beta 5, latest Aurora and latest Nightly.
You need to log in before you can comment on or make changes to this bug.