Closed Bug 969989 Opened 8 years ago Closed 8 years ago

Bug 753203 broke MOZ_APP_NAME handling

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox29 fixed, firefox30 fixed, firefox31 fixed)

RESOLVED FIXED
mozilla30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

MOZ_APP_NAME is either set from --with-app-name, from branding, or derived from MOZ_APP_BASENAME[1], which, itself is either set from --with-app-basename, or from branding.

But 753203 moved MOZ_APP_NAME derivation from MOZ_APP_BASENAME, doing it before branding is included...

1. http://hg.mozilla.org/mozilla-central/file/c71a1f6f6f2f/configure.in#l8500
Bug 753203 did the move for this snippet to work:

    if test "$MOZ_APP_NAME" = firefox -o "$MOZ_APP_NAME" = mobile/android ; then

Not only was that wrong[1], but it didn't even make it to the final landing, making the MOZ_APP_NAME move moot.

1. MOZ_APP_NAME is a branding thing and must never be used for such tests. They must use MOZ_BUILD_APP instead.
Attachment #8372944 - Flags: review?(ted)
Attachment #8372944 - Flags: review?(ted) → review+
https://hg.mozilla.org/mozilla-central/rev/eab2145f30e4
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Comment on attachment 8372944 [details] [diff] [review]
Move MOZ_APP_NAME derivation from MOZ_APP_BASENAME where is was

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Problem introduced by bug 753203
User impact if declined: build issues for derivatives using a different branding
Testing completed (on m-c, etc.): Landed on m-c when it was 30. Used on Debian for a while
Risk to taking this patch (and alternatives if risky): Low. It is a build system change. In essence, it is NPOTB, although the code that is moved is executed during the build. I should have requested approval before, but forgot :(
String or IDL/UUID changes made by this patch: None
Attachment #8372944 - Flags: approval-mozilla-beta?
Attachment #8372944 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.