Mass-change with no bugs selected gives software error.

VERIFIED DUPLICATE of bug 90333

Status

()

Bugzilla
Creating/Changing Bugs
--
critical
VERIFIED DUPLICATE of bug 90333
17 years ago
6 years ago

People

(Reporter: zach, Assigned: myk)

Tracking

Details

(Reporter)

Description

17 years ago
When I did a mass-change today of all BiDi Hebrew and Arabic bugs to 
me for qa, I got the following software error:

Software error:

SELECT bit, bit & 192 != 0, bit & bugs.groupset != 0 FROM groups, bugs 
WHERE isbuggroup != 0 AND bug_id = ORDER BY bit : You have an error 
in your SQL syntax near 'ORDER BY bit ' at line 4 at globals.pl line 214.

What I realized soon after this was that I had not pressed the "check all" 
button, so I was making a mass-change to no bugs. We need to display 
an error message saying:

Please select one or more bugs to change

Comment 1

17 years ago
Yeah, I can definitely reproduce here. 

Software error:
SELECT bit, bit & 9223372036854775807 != 0, bit & bugs.groupset != 0 FROM
groups, bugs WHERE isbuggroup != 0 AND bug_id = ORDER BY bit : You have an error
in your SQL syntax near 'ORDER BY bit ' at line 4 at globals.pl line 214.

Comment 2

17 years ago
I'll attach the POST data to help the trace:

product=--do_not_change--&
version=--do_not_change--& 
rep_platform=All&
priority=--do_not_change--&
component=--do_not_change--&
bug_severity=--do_not_change--&
target_milestone=--do_not_change--&
qa_contact=--do_not_change--&
masscc=&
ccaction=add&
keywords=&
keywordaction=add&
multiupdate=Y&
comment=&
bit-256=-1&
knob=none&
resolution=FIXED&
assigned_to=kiko%40async.com.br

*** This bug has been marked as a duplicate of 90333 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
blah
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.