Geolocation no longer working in Nightly

VERIFIED FIXED in Firefox 28, Firefox OS v1.3

Status

()

Core
Geolocation
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Elad Alfassa, Assigned: gwagner)

Tracking

({regression, testcase})

Trunk
mozilla30
x86_64
All
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox28 verified, firefox29 verified, firefox30- verified, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
GeoLocation simply stopped working in Nightly sometime in the last few days, navigator.geolocation.getCurrentPosition never calls the callbacks (no error either).
Also not working on Win7 x64 m-c tinderbox build:
cset: https://hg.mozilla.org/mozilla-central/rev/7133bb431eba
Keywords: regression, regressionwindow-wanted
OS: Windows 8.1 → All
Component: Untriaged → Geolocation
Keywords: testcase-wanted
Product: Firefox → Core
Version: unspecified → Trunk
(Reporter)

Comment 2

4 years ago
Created attachment 8373072 [details]
Quick Testcase

Quick testcase: if it works you should see an alert box.
Duplicate of this bug: 971210
Severity: normal → major
Keywords: testcase-wanted → testcase

Comment 4

4 years ago
works for me on 30.0a1 (2014-02-09) Mac.  I'll try windows tonight.
Assignee: nobody → doug.turner
Testcase doesn't show an alert. Windows 8.1, current Nightly. I noticed Google maps also fails to locate me since a week or so?
Duplicate of this bug: 973854
WFM on OS X, and fails on Windows. No messages in the browser/error consoles.

Comment 8

4 years ago
This is working for me on Windows 8.1 desktop in nightly from a checkout this morning, failing in aurora and beta.

Comment 9

4 years ago
(In reply to Jim Mathies [:jimm] from comment #8)
> This is working for me on Windows 8.1 desktop in nightly from a checkout
> this morning, failing in aurora and beta.

Correction - I get the doorhanger in my local build, but once I approve it I get an error for the actual lookup. I don't see the doorhanger in these other builds.

Comment 10

4 years ago
(In reply to Jim Mathies [:jimm] from comment #9)
> (In reply to Jim Mathies [:jimm] from comment #8)
> > This is working for me on Windows 8.1 desktop in nightly from a checkout
> > this morning, failing in aurora and beta.
> 
> Correction - I get the doorhanger in my local build, but once I approve it I
> get an error for the actual lookup. I don't see the doorhanger in these
> other builds.

On this system, google returns an error for the request - 400, bad request. If you want the full log with mac addresses and all that ping me on irc.
Related to bug 962492?
gijs, part of it.  that bug fixes the door hanger from showing up on some platforms.
(In reply to Jim Mathies [:jimm] from comment #9)

> Correction - I get the doorhanger in my local build, but once I approve it I
> get an error for the actual lookup.

I think this is expected, unless you've configured your build to use your own Google API key (since the official keys are only provided within releng's build process for releases). [On Windows. OS X still works because we use Core Location instead of Google.]
Working again in the current official Nightly. I tried to bisect what broke/fixed this, but all my own builds seemed to work (at least, displayed the doorhanger), so I'm a bit confused.
(In reply to Gian-Carlo Pascutto (:gcp) from comment #14)
> Working again in the current official Nightly. I tried to bisect what
> broke/fixed this, but all my own builds seemed to work (at least, displayed
> the doorhanger), so I'm a bit confused.

I just tested the latest m-c win32 hourly build, and Geolocation is still not working here.  

Tested using https://bugzilla.mozilla.org/show_bug.cgi?id=970112 - No map ever appears
>No map ever appears

I get an alert with [Object Location], which is what I think it's supposed to do? Other geolocation sites works as well. (This is on Windows)

Comment 17

4 years ago
I installed a nightly build in a user writable folder and geo location started working again.
Depends on: 962492
Okay, after some more testing: the Windows 7 machine works, the Windows 8.1 one doesn't.
Still does not work here on win7 x64, today's Nightly. 

The test-case supplied here in the bug or this link do anything:

http://www.mozilla.org/en-US/firefox/geolocation/

No prompt to allow, or information is displayed.

Using the link I click in the the hyperlink:  "give it a try" 
A map opens - click the button - loading/spinning forever.  

Works in IE11.

Comment 20

4 years ago
This should be fixed on tomorrow's nightly.
Depends on: 974100
No longer depends on: 962492

Comment 21

4 years ago
Not sure if this or bug 974100 should get the status flags. Since this describes the core problem, seems fitting to track on this so we can verify this specific problem is fix on all branches.
status-firefox28: --- → affected
status-firefox29: --- → affected
status-firefox30: --- → fixed
tracking-firefox28: --- → ?
tracking-firefox29: --- → ?
tracking-firefox30: --- → ?
We will track this bug to make sure the fixes get uplifted to beta & aurora.
tracking-firefox28: ? → +
tracking-firefox29: ? → +
tracking-firefox30: ? → -

Comment 23

4 years ago
Appears fixed in 2-20 nightly on Windows.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regressionwindow-wanted
Resolution: --- → FIXED

Updated

4 years ago
Keywords: verifyme
Assignee: doug.turner → anygregor
Target Milestone: --- → mozilla30

Comment 24

4 years ago
Bug Triage day 24/2/2014

Validated the bug in Win 7 - 64 bit - Nightly B30, beta 28  and Aurora B29. 
I can see the alert box displaying.
Works fine for me
(Assignee)

Updated

4 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 974100
(Assignee)

Updated

4 years ago
Whiteboard: [systemsfe]
tracking-firefox28: + → ---
tracking-firefox29: + → ---
status-b2g-v1.3: --- → fixed
status-firefox28: affected → fixed
status-firefox29: affected → fixed
Resolution: DUPLICATE → FIXED

Comment 26

4 years ago
I was unable to reproduce this issue on 2 different Windows 7 64bit machines nor on Ubuntu 13.10 64bit with Nightly from 2014-02-09 and from 2014-02-07. With the testcase from comment 2 I see the alert box with both Firefox 28 beta 9 (Build ID: 20140306171728) and the above mentioned Nightly builds.
Am I missing something? Thanks in advance!
Flags: needinfo?(anygregor)
QA can't reproduce the initial issue.
Elad, Jim could you please confirm it's fixed now?
Flags: needinfo?(jmjeffery)
Flags: needinfo?(elad)

Comment 28

4 years ago
wfm in nightly all the way through to resolution with this test case - 
http://www.mathies.com/mozilla/geolocation.html
Could you please also check beta and aurora?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/28.0b9-candidates/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora/

Comment 30

4 years ago
(In reply to Paul Silaghi, QA [:pauly] from comment #29)
> Could you please also check beta and aurora?
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/28.0b9-candidates/
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora/

confirmed working for both builds on Win7 using my test case.
Thank you, Jim.
Status: RESOLVED → VERIFIED
status-firefox28: fixed → verified
status-firefox29: fixed → verified
status-firefox30: fixed → verified
Flags: needinfo?(jmjeffery)
Flags: needinfo?(elad)
Flags: needinfo?(anygregor)
Keywords: verifyme
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
You need to log in before you can comment on or make changes to this bug.