URL bar isn't decoded in some edge cases

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
--
trivial
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

unspecified
seamonkey2.27

SeaMonkey Tracking Flags

(seamonkey2.26 fixed, seamonkey2.27 unaffected, seamonkey2.28 wontfix, seamonkey2.29 wontfix, seamonkey2.30 wontfix)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
When a link in a non-UTF8 document links to a page with special characters, those characters are decoded correctly in the status bar when the link is hovered, but they are not decoded correctly in the URLbar when the link is visited.

Steps to reproduce problem:
1. Visit the linked URL
2. Examine the status bar as each link is hovered
3. Visit each link and note the URLbar contents
(Assignee)

Comment 1

4 years ago
Created attachment 8373082 [details] [diff] [review]
Proposed patch

The gotcha with unEscapeURIForUI is that it returns the original value rather than throwing an exception.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8373082 - Flags: review?(philip.chee)

Comment 2

4 years ago
[comment] Please file a followup bug to port the relevant bits from:
Bug 909264 - ASCII control characters stripped from address bar
Bug 582186 - Zero-Width-Non-Joiner not rendered correctly in the address bar
Bug 922530 - U+061C ARABIC LETTER MARK displays as tofu (i.e. is not invisible)
  http://hg.mozilla.org/mozilla-central/rev/30a7b37f0892#l1.12

Comment 3

4 years ago
Comment on attachment 8373082 [details] [diff] [review]
Proposed patch

r+ since it works if you left-click to follow the links.
Attachment #8373082 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 4

4 years ago
Pushed comm-central changeset ed8c317c7a96.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Target Milestone: --- → seamonkey2.27

Updated

4 years ago
Blocks: 1018792
Pushing to comm-release for SeaMonkey 2.26.1

$ hg tip
changeset:   20184:fd910d1fd8f0
branch:      SEA_2_26_1_RELBRANCH
tag:         tip
user:        Neil Rashbrook <neil@parkwaycc.co.uk>
date:        Fri Feb 21 01:03:14 2014 +0000
summary:     Bug 970121 Try to decode the URL in more cases r=Ratty
status-seamonkey2.26: --- → fixed
(Assignee)

Comment 6

4 years ago
This caused a regression, because UnEscapeURIForUI unescapes reserved characters (so for instance %2F in a link shows as / in the status bar and now in the URL bar too).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

4 years ago
(In reply to comment #4)
> Pushed comm-central changeset ed8c317c7a96.

Backed out in comm-central changeset 3fdd4044a6e1.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-seamonkey2.27: --- → unaffected
status-seamonkey2.28: --- → affected
status-seamonkey2.29: --- → affected
status-seamonkey2.30: --- → wontfix
Resolution: --- → WONTFIX
(Assignee)

Comment 8

4 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/135de3391f57
http://hg.mozilla.org/releases/comm-beta/rev/a17a400e2733
status-seamonkey2.28: affected → wontfix
status-seamonkey2.29: affected → wontfix
You need to log in before you can comment on or make changes to this bug.