Port is being ignored in networks.txt for secure connections

UNCONFIRMED
Assigned to

Status

Other Applications
ChatZilla
UNCONFIRMED
4 years ago
4 years ago

People

(Reporter: jeremy020202, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8373199 [details]
networks.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:24.0) Gecko/20100101 Firefox/24.0 Waterfox/24.0 (Beta/Release)
Build ID: 20131007042817

Steps to reproduce:

Add a network to networks.txt, with "issecure" set to true and "port" set to any value besides the default (9999). The bug occurs regardless of which line occurs first in networks.txt. Version details: ChatZilla 0.9.90.1 [Firefox 24.0/20131007042817]


Actual results:

I specified port number 6697 in networks.txt. When I use the /networks command and click on the network I've added, it attempts to connect to port 9999.


Expected results:

Chatzilla should have connected to port 6697.
Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 SeaMonkey/2.27a1 ID:20140210003001 c-c:c7fc213e0bcf m-c:ecf20a2484b6

cZ 0.9.90.1

Strange. I see the opposite (normal) behaviour: I have a networks.txt with the following entry for moznet:

	START 0
		"name" "moznet"
		"displayName" "moznet"
		"isupportsKey" "Mozilla"
		START <Array> servers
			START 0
				"hostname" "irc.mozilla.org"
				"port" 6697
				"isSecure" true
			END
			START 1
				"hostname" "concrete.mozilla.org"
				"port" 6697
				"isSecure" true
			END
			START 2
				"hostname" "concrete2.mozilla.org"
				"port" 6697
				"isSecure" true
			END
			START 3
				"hostname" "sand.mozilla.org"
				"port" 6697
				"isSecure" true
			END
			START 4
				"hostname" "gravel.mozilla.org"
				"port" 6697
				"isSecure" true
			END
			START 5
				"hostname" "irc.mozilla.org"
				"port" 6667
				"isSecure" false
			END
			START 6
				"hostname" "dust.mozilla.org"
				"port" 6697
				"isSecure" true
			END
		END
	END

and I'm currently on an ircs connection to the first of these on the correct port, as can be seen from the following line in the moznet network tab, somewhere above the latest motd:

[Monday 17:55:49]	[INFO]	Connecting to irc://moznet/ (ircs://irc.mozilla.org:6697/)… [Cancel]
P.S. I connect to moznet at every ChatZilla startup, by means of an irc://moznet line in ChatZilla → Global Settings → Startup → Locations
oops: ChatZilla → Preferences → Global Settings → etc.
You need to log in before you can comment on or make changes to this bug.